Authorization error with GO worker on Camunda 8

Update: after I wrote question/issue below, I changed the Audience parameter to exclude the port number at the end of ZEEBE_ADDRESS (which is provided in the download from console for client credentials). I left the :403 port number at the end of ZEEBE_ADDRESS for the GatewayAddress parameter. I was just guessing/experimenting, but this combination of values for parameters in zbc calls below seemed to work (i.e., I got topology back from ZEEBE).

I am following the documentation and sample code to build a GO client worker on Camunda 8 but get the following error after requesting topology from Zeebe (i.e., topology, err := client.NewTopologyCommand().Send(ctx))

failed to apply token: failed to obtain access token: oauth2: cannot fetch token: 401 Unauthorized
Response: {“error”:“access_denied”,“error_description”:“Unauthorized”}

For zbc.NewOAuthCredentialsProvider(), I am providing the following client credentials downloaded from the console as parameters:

  • Audience: ZEEBE_ADDRESS

NOTE: GO code example does not specify a parameter for AuthorizationServerURL in zbc.NewOAuthCredentialsProvider(). Regardless, I have experimented including ZEEBE_AUTHORIZATION_SERVER_URL as a parameter, but it does not change results.

Has anyone gotten the GO client to work using sample code in documentation? Can anyone suggest something new for me to try. I feel I am hitting head against wall at this point.

Thank you,