Camunda BPM engine not running in Chrome, only displaying code

Hi folks, I want to run processes locally on my Mac and was able to install the Java JDK, Apache Maven, and Eclipse, and I have Chrome. Unfortunately, I’m stuck on one thing. When I launch the “start-camunda.sh” file it opens up in the Chrome browser but it just displays the code - it does not run the engine. It displays the following message but I am unsure how to fix it. Any help? Thanks in advance!

Here is what it displayed in Chrome:

file:///Users/jamesd/camunda-bpm-tomcat-7.8.0/start-camunda.sh

#!/bin/sh

export CATALINA_HOME="$(dirname “$0”)/server/apache-tomcat-8.0.47"

BROWSERS=“gnome-www-browser x-www-browser firefox chromium chromium-browser google-chrome”

echo “starting camunda BPM platform on Tomcat Application Server”;

if [ -z “$BROWSER” ]; then
for executable in $BROWSERS; do
BROWSER=which $executable 2> /dev/null
if [ -n “$BROWSER” ]; then
break;
fi
done
fi

if [ -z “$BROWSER” ]; then
(sleep 15; echo -e “We are sorry… We tried all we could do but we couldn’t locate your default browser… \nIf you want to see our default website please open your browser and insert this URL:\nhttp://localhost:8080/camunda-welcome/index.html”:wink: &
else
(sleep 5; $BROWSER “http://localhost:8080/camunda-welcome/index.html:wink: &
fi

/bin/sh “$(dirname “$0”)/server/apache-tomcat-8.0.47/bin/startup.sh”

Hi @JamesD,

start-camunda.sh must be run in a terminal. Can you please try that?

Cheers,
Thorben

Thanks, Thorben. Do I need to put a command before “start-camunda.sh”? I tried it without anything but that and it returned: “file /Users/jamesd/start-camunda.sh does not exist.” So I’m guessing I have not installed it properly. I’ll try reinstalling.

Hi @JamesD,

Unpack the downloaded zip file. Then open a terminal and navigate to the location where start-camunda.sh is located. Then type ./start-camunda.sh.

Cheers,
Thorben

Thanks, Thorben. Unfortunately, it says “No such file or directory.” It’s not installed properly. I unzipped the file at my root user directory and have attempted to open it from there but it is not working:

jamesd$ file Users/jamesd/camunda-bpm-tomcat-7.8.0.2/start-camunda.sh

Any further suggestions? Thanks!

Hi,

You should not have ‘file’ in the cmd line!

as @thorben said better to navigate directly to the location where the start-camunda.sh file is and just type

./camunda.sh

my url - http://localhost:8080/camunda-welcome/index.html

Access Error: 404 – Not Found

Cannot open document for: /camunda-welcome/index.html

m getting this error.

Hi, I have the same error. Have u ever run Camunda on your mac? Can you tell me what you did in order to run it? I can’t always open the file “start-camunda.sh”. Thanks so much!

Hi @Annie_Le
Welcome to the forum.

Can you describe exactly whats happening when you try to run the file? Are you running it from the terminal?

Hi Niall, so happy to receive your messenger.

I have ever seen your tutorial videos on youtube and done the same steps by steps as the instructions. With Window it’s so easy to install Camunda. But I use Mac Air and I find it is so hard to do that.

I couldn’t run the file “start-camunda.sh” on Terminal. Although I tried my best, but I had always the error “the file does not exist”. Should I install Java Home firstly? Please tell me what should I do
It took me some days to run camunda but I failed ;((

You should indeed install Java - make sure to install Java 11.
The problem is probably that your terminal is not open in the same directory as the file.

Also - after you’ve installed Java 11 - try to follow this:

omg, I have not seen a small mistake. Now I can run the file on Terminal. Thank you so much!

1 Like