Camunda Optimize on Openshift

We have installed Camunda Engine on Openshift Kubernetes platform and enabled authorization for the engine rest APIs.
Now, we want to use the environment-config.yaml in Optimize to toggle authentication ‘on’ as per Installation |
Since we are on Openshift, we cannot run the ‘docker run…’ as mentioned in the link. Instead we are hoping that using an environment variable ABSOLUTE_PATH_ON_HOST_TO_CONFIGURATION_FILE= file would work. However that does not seem to work. Optimize doe snot seems to be aware of the config file at startup and connection to Camunda engine fails with authorization issue.
Do you know if there is a way to pass the path to environment-config.yaml in an environment variable that Optimize can use at startup ?

Thank & Regards,

It’s solved now. The ABSOLUTE_PATH_ON_HOST_TO_CONFIGURATION_FILE cannot be specified as an environment variable.
Instead I did the following :

  1. Create a configmap with the environment-config.yaml file after setting the needed properties there.
  2. Modify the pod yaml file to load the configs from the config map:

- configMapRef: