Camunda php sdk - phpunit 4.1.0 support?

Recently I integrated camunda php sdk into magento(php), while both dependancy get conflict. magento require “phpunit/phpunit”: “4.1.0” but camunda require “phpunit/phpunit”: "3.7.21"

my question is when camunda support phpunit 4.1.0?

1 Like

Hi @busean,

is a community extension, so there is no fixed roadmap related to it at Camunda itself. Would you be interested in providing a pull request for it? You can always fork it here


1 Like

Hi @aakhmerov thanks for the response

in your shared link use phpunit 4.6.0

Magento 2 has a hard dependency on PHPUnit version 4.1.0

for your easy reference, how I tried to integrate into magento 2

temporary I can fixed like change magento2 phpunit version to 3.7.21 but this is not a good practice in magento, it may be affect some functionality.

so I am looking for the solution or suggestion for camunda phpunit 4.1.0. If I am wrong in any place correct me.

Hi @busean,

I am not a php expert, but I think that the problem is that you are using camunda-bpm-php-sdk in a stable version 1.1.1, which depends on php-unit 3.7.21, while latest master depends on 4.6, so you should just use latest master somehow. I cannot tell you how to do that though :slight_smile:.


Hi busean.

Another possibility is always to use the REST API directly and code the communication yourself. Than you do not depend on anything from the community extension.


1 Like