Camunda8 install issue

Hi Team,

I was trying to install Camunda 8 using helm. Facing this issue now:

camunda8-postgresql-0 0/1 ErrImagePull 0 58s

Failed to pull image “docker.io/bitnami/postgresql:14.2.0-debian-10-r35”: rpc error: code = Unknown desc = Error response from daemon: Get https://registry-1.docker.io/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)

Is anything changed in Camunda helm chat. It is not able to pull the image from Docker. The same was working for me before.

Any input will be appreciated.

Thanks,
Sudhanshu Dash

Hey @Sudhanshu_Sekhar,
I have just tried it on my local machine using the latest helm charts with KIND Kubernetes. Before starting them I made sure I had none of the images pre-loaded.
image

Long story short: It is working at least for me.
Have you tried fetching the postgres image separately to see if this is working?

Best,
Thomas

Hi @Hafflgav,

I was just trying to install Camunda 8 using helm by referring
link: camunda-platform-helm/README.md at main · camunda/camunda-platform-helm · GitHub

FYI:

Thanks,
Sudhanshu Dash

Hey @Sudhanshu_Sekhar,
have you added this helm repo?

https://helm.camunda.io

and recently run the update command?

helm repo update

To me it looks like a problem with your machine rather than a Helm chart problem. :thinking:
Best,
Thomas

Yes, I have added the helm repo mentioned above and also updated it.

Let me delete the delete and create a new CCE. And then I’ll install Camunda8 again.

Thanks @Hafflgav.

Any updates or movement here? I am seeing a similar issue on AWS / EKS.

Yes, I created a new CCE and install Camunda 8 using helm and that worked.

Now I’m trying to enable ingress controller where I’m facing issue.

Hi,

This looks like a DNS issue accessing Docker Hub (where the Docker images are stored). It’s not related to Helm or Camunda.

First, check if your machine or cluster is actually able to access the internet.
If there is internet access, then try to change your DNS to one of the DNS resolves like 1.1.1.1 or 8.8.8.8

Here is a post from Docker forums with the same issue: