CamundaBpmRun v7.16.0 using Java 11.0.9.1 on raspberrypi

Hi together,

I’m new to camunda.
I run an raspberry pi with debian and node-red.
My idea is to have camunda running on rasppi.
Tomcat 10.0.14 is running.
I’m on step: Choose between default and production configuration
in Camunda Platform Run | docs.camunda.org
In Putty I type: bash start.sh --production

The output gives this error message:

> 2021-12-23 23:12:13.310  INFO 4617 --- [           main] org.camunda.feel.FeelEngine              : Engine created. [value-mapper: CompositeValueMapper(List(org.camunda.feel.impl.JavaValueMapper@6b143b, org.camunda.spin.plugin.impl.feel.integration.SpinValueMapper@2bd3c4)), function-provider: org.camunda.bpm.dmn.feel.impl.scala.function.CustomFunctionTransformer@1799544, clock: SystemClock, configuration: Configuration(false)]
> 2021-12-23 23:12:13.905  INFO 4617 --- [           main] com.zaxxer.hikari.HikariDataSource       : HikariPool-1 - Starting...
> 2021-12-23 23:12:16.907 ERROR 4617 --- [           main] com.zaxxer.hikari.pool.HikariPool        : HikariPool-1 - Exception during pool initialization.
> 
> org.h2.jdbc.JdbcSQLException: Fehler beim Erzeugen der Datei "/opt/camunda/camunda-h2-test-production"
> Error while creating file "/opt/camunda/camunda-h2-test-production" [90062-190]

Permissions are:
drwxr-xr-x 2 root root 4096 Dez 23 23:00 camunda-h2-default
drwxr-xr-x 6 root root 4096 Dez 23 23:10 configuration
drwxr-xr-x 6 root root 4096 Okt 5 08:45 internal
-rw-rw-r-- 1 root root 10351 Okt 5 08:45 LICENSE
-rw-rw-r-- 1 root root 328059 Okt 5 08:33 LICENSE_BOOK-7.16.0.txt
-rw-rw-r-- 1 root root 547 Okt 5 08:45 NOTICE
-rw-rw-r-- 1 root root 1681 Okt 5 08:45 README.txt
-rwxr-xr-x 1 root root 3086 Okt 5 08:45 start.bat
-rwxr-xr-x 1 root root 2987 Okt 5 08:45 start.sh

Does anybody have an idea what the mistake could be?

Thank you very much in advance

Martin

Just guessing here - since there’s a few unknowns.

Since the permissions all appear to be root and rpi usually runs as raspberry, it looks like the directory probably doesn’t have permissions that raspberry would need to create a file in that directory.

If you do
ls -altd /opt/camunda
What do you get?

I hope you’re not running Camunda as root… that wouldn’t be a good idea (though in a container world, it’s becoming pretty common thing to do: run apps as root in the container … I don’t really support that idea, and still suggest dropping to unprivileged user)

Thank you for your fast reply.

The output is:
drwxr-xr-x 5 root root 4096 Dez 23 23:45 /opt/camunda

So I have to change the permissions to an existing user, exept root?

Just to see if that is in fact the issue, try

sudo ./start.sh

instead of running ./start.sh as raspberry.
If that solves it, then we can figure out how to fix it properly.

I have started as you mentioned and now the rasppi is like frozen.
I have no access to Node-red, …

The out put is:

pi@raspberrypi:/opt/camunda $ sudo ./start.sh
JAVA_HOME is not set. Unexpected results may occur.
Set JAVA_HOME to the directory of your local JDK to avoid this message.
REST API enabled
WebApps enabled
Swagger UI enabled
Invoice Example included - needs to be enabled in application configuration as well
classpath: ./internal/webapps/,./internal/rest/,./internal/swaggerui,./internal/example,./configuration/userlib/,./configuration/keystore/


/ | __ _ _ __ ___ _ _ _ __ | | __ _ | _ | | __ | | / | ___ _ __ _ __ ___ | _ \ _ _ _ __
| | / | '_ _ | | | | ’ \ / |/ _ | | |) | |/ | __| |_ / _ \| '__| '_ _ \ | |) | | | | ’

| |
| (
| | | | | | | |
| | | | | (
| | (| | | __/| | (| | || | () | | | | | | | | | _ <| || | | | |
_/_,|| || ||_,|| ||_,|_,| || ||_,|_|| _/|| || || || |_| _\,|| |_|

Spring-Boot: (v2.5.4)
Camunda Platform: (v7.16.0)

2021-12-24 00:57:20.329 INFO 5835 — [ main] org.camunda.bpm.run.CamundaBpmRun : Starting CamundaBpmRun v7.16.0 using Java 11.0.9.1 on raspberrypi with PID 5835 (/opt/camunda/internal/camunda-bpm-run-core.jar started by root in /opt/camunda)
2021-12-24 00:57:20.363 INFO 5835 — [ main] org.camunda.bpm.run.CamundaBpmRun : No active profile set, falling back to default profiles: default
2021-12-24 00:57:37.091 INFO 5835 — [ main] o.s.b.w.embedded.tomcat.TomcatWebServer : Tomcat initialized with port(s): 8080 (http)
2021-12-24 00:57:37.252 INFO 5835 — [ main] o.apache.catalina.core.StandardService : Starting service [Tomcat]
2021-12-24 00:57:37.254 INFO 5835 — [ main] org.apache.catalina.core.StandardEngine : Starting Servlet engine: [Apache Tomcat/9.0.52]
2021-12-24 00:57:38.059 INFO 5835 — [ main] o.a.c.c.C.[Tomcat].[localhost].[/] : Initializing Spring embedded WebApplicationContext
2021-12-24 00:57:38.061 INFO 5835 — [ main] w.s.c.ServletWebServerApplicationContext : Root WebApplicationContext: initialization completed in 17026 ms
2021-12-24 00:57:38.465 INFO 5835 — [ main] .c.b.s.b.s.r.CamundaJerseyResourceConfig : Configuring camunda rest api.
2021-12-24 00:57:38.751 INFO 5835 — [ main] .c.b.s.b.s.r.CamundaJerseyResourceConfig : Finished configuring camunda rest api.
2021-12-24 00:57:42.320 INFO 5835 — [ main] org.camunda.bpm.spring.boot : STARTER-SB040 Setting up jobExecutor with corePoolSize=3, maxPoolSize:10
2021-12-24 00:57:43.303 INFO 5835 — [ main] org.camunda.bpm.engine.cfg : ENGINE-12003 Plugin ‘CompositeProcessEnginePlugin[genericPropertiesConfiguration, camundaDeploymentConfiguration, camundaProcessEngineConfiguration, camundaDatasourceConfiguration, camundaJobConfiguration, camundaHistoryConfiguration, camundaMetricsConfiguration, camundaAuthorizationConfiguration, CreateAdminUserConfiguration[adminUser=AdminUserProperty[id=demo, firstName=Demo, lastName=Demo, email=demo@localhost, password=******]], failedJobConfiguration, disableDeploymentResourcePattern, eventPublisherPlugin, ApplicationContextClassloaderSwitchPlugin, SpringBootSpinProcessEnginePlugin]’ activated on process engine ‘default’
2021-12-24 00:57:43.342 INFO 5835 — [ main] org.camunda.bpm.spring.boot : STARTER-SB021 Auto-Deploying resources: []
2021-12-24 00:57:43.374 INFO 5835 — [ main] org.camunda.bpm.spring.boot : STARTER-SB020 ProcessApplication enabled: autoDeployment via springConfiguration#deploymentResourcePattern is disabled
2021-12-24 00:57:43.380 INFO 5835 — [ main] o.c.b.s.b.s.event.EventPublisherPlugin : EVENTING-001: Initialized Camunda Spring Boot Eventing Engine Plugin.
2021-12-24 00:57:43.382 INFO 5835 — [ main] o.c.b.s.b.s.event.EventPublisherPlugin : EVENTING-003: Task events will be published as Spring Events.
2021-12-24 00:57:43.383 INFO 5835 — [ main] o.c.b.s.b.s.event.EventPublisherPlugin : EVENTING-005: Execution events will be published as Spring Events.
2021-12-24 00:57:43.405 INFO 5835 — [ main] o.c.b.s.b.s.event.EventPublisherPlugin : EVENTING-007: History events will be published as Spring events.
2021-12-24 00:57:43.454 INFO 5835 — [ main] org.camunda.spin : SPIN-01010 Discovered Spin data format provider: org.camunda.spin.impl.json.jackson.format.JacksonJsonDataFormatProvider[name = application/json]
2021-12-24 00:57:45.105 INFO 5835 — [ main] org.camunda.spin : SPIN-01010 Discovered Spin data format provider: org.camunda.spin.impl.xml.dom.format.DomXmlDataFormatProvider[name = application/xml]
2021-12-24 00:57:45.190 INFO 5835 — [ main] org.camunda.spin : SPIN-01009 Discovered Spin data format: org.camunda.spin.impl.xml.dom.format.DomXmlDataFormat[name = application/xml]
2021-12-24 00:57:45.191 INFO 5835 — [ main] org.camunda.spin : SPIN-01009 Discovered Spin data format: org.camunda.spin.impl.json.jackson.format.JacksonJsonDataFormat[name = application/json]
2021-12-24 00:57:46.910 INFO 5835 — [ main] org.camunda.bpm.dmn.feel.scala : FEEL/SCALA-01001 Spin value mapper detected
2021-12-24 00:57:47.480 INFO 5835 — [ main] org.camunda.feel.FeelEngine : Engine created. [value-mapper: CompositeValueMapper(List(org.camunda.feel.impl.JavaValueMapper@9486c0, org.camunda.spin.plugin.impl.feel.integration.SpinValueMapper@27d39d)), function-provider: org.camunda.bpm.dmn.feel.impl.scala.function.CustomFunctionTransformer@166c667, clock: SystemClock, configuration: Configuration(false)]
2021-12-24 00:57:48.248 INFO 5835 — [ main] com.zaxxer.hikari.HikariDataSource : HikariPool-1 - Starting…
2021-12-24 00:57:50.255 INFO 5835 — [ main] com.zaxxer.hikari.pool.PoolBase : HikariPool-1 - Driver does not support get/set network timeout for connections. (null)
2021-12-24 00:57:50.303 INFO 5835 — [ main] com.zaxxer.hikari.HikariDataSource : HikariPool-1 - Start completed.

And here it hangs, it doesn’t finish the start.sh

That seems to suggest that the cause was in fact permissions.

You won’t need Tomcat 10 installed/running, since you can see in the log you posted that Tomcat 9.0.52 is being started.

Personally, I would be temped at this point to remove the /opt/camunda directory, and unzip the files again (this time as pi rather than root). That being said, I don’t know if your pi has enough resources to be able to run the camunda server, which is why it seems like it is frozen (likely all the CPU are pinned)

Ok,

I’ll try your ideas after having some hours of sleep.
Do you know if there is a possibility to terminate the started start.sh? Kill, …?

Sadly, I don’t know of a clean stop command.

Hey @mssib28 ,

I am not an expert on how to run Camunda on a Rasperrypi! But it sounds like a nice project! If you use CamundaRun you don’t need Tomcat. From your Error Log above it seems like that you have not installed a JDK.In order to have Camunda working as expected you need to install Java and a JDK.

Looking forward to hearing more about this project
Cheers
Nele

Hi @Nele ,

thank you very much for your information.
I’ll try that, thank you.
I’m on the way to “reset” all back to the beginning and make a new start with that.

Have a merry christmas,

Martin

Hi @ GotnOGuts,

I used ‘shutdown -r now’.
Then after reboot I got access to the Raspberry.

Greetings

Martin

Hi @Nele,
I used the recommented procedure, but I get the message in the browser:

Whitelabel Error Page

This application has no explicit mapping for /error, so you are seeing this as a fallback.
Sat Dec 25 15:49:06 CET 2021
There was an unexpected error (type=Not Found, status=404).

I did:

  • Download the camunda-bpm-run-7.16.0.tar.gz
  • cd /tmp/camunda → here is the camunda-bpm-run-7.16.0.tar.gz placed
  • tar xfvz camunda-bpm-run-7.16.0.tar.gz
  • ./start.sh

Greetings

Martin

@Nele and @GotnOGuts,

life could be so easy.
I used the CamundaRun and had then to use in the browsers address field:
http://192.168.178.100:8080/camunda/app/welcome/default/#!/login
That’s it. Now it works within a few minutes, unbelivable after so much hours without success.

Thank you both very much in advance.

Greeitngs

Martin

1 Like

Hey @mssib28 ,

I am happy that it runs now on your Raspberry! What kind of process are you orchestrating on your RasberryPi? Sounds like a nice Christmas Hacking project!

Cheers
Nele

Hi @Nele,
I’m new with BPM.
I’ll try to use Camunda with Node-red.
Node-Red is running on Raspberry and is used at the moment, to aquire ambient data from micrcontrollers ESP8266 and ESP32 equipped with sensors, camera, Fritz router, … Also lights and socket can be switched by pc, smartphone or Alexa.
Aquired data are stored in a MySQL-database, this data are also used in Node-Red.

Greetings
Martin

1 Like

@mssib28
Glad to hear you got it sorted out!
I dusted off a Pi over the last two weeks and was trying to dig into what it would take to get your use-case running - I guess I don’t need to do that now :slight_smile:

Your overall use-case (as described to Nele) is actually quite close to something I’ve been trying to get myself started on for a while - collecting and collating data from a set of meters. Maybe with your proof that it can be done, I’ll get it done too.

2 Likes