Cannot access Nexus repo to get EE dependencies

I am trying to access the following repo URL in my POM file to download the EE dependencies.

https://app.camunda.com/nexus/content/repositories/camunda-bpm-ee

However I get the following error message when trying in the browser:

image

It worked a few weeks ago or so, so is it down or has it changed since?

Here is my POM file entry:

<repositories>
  <repository>
    <id>camunda-bpm-nexus-ee</id>
    <name>camunda-bpm-nexus</name>
    <url>
      https://app.camunda.com/nexus/content/repositories/camunda-bpm-ee
    </url>
  </repository>
</repositories>

I have also set the credentials in the /.m2/settings.xml file. These have not changed since it was working last either.

OK, so the problem is running mvn clean install from with my VSC remote development container, where I get the following error:

Non-resolvable import POM: Could not transfer artifact org.camunda.bpm:camunda-bom:pom:7.15.0-ee from/to camunda-bpm-nexus-ee (https://app.camunda.com/nexus/content/repositories/camunda-bpm-ee/): authentication failed for https://app.camunda.com/nexus/content/repositories/camunda-bpm-ee/org/camunda/bpm/camunda-bom/7.15.0-ee/camunda-bom-7.15.0-ee.pom, status: 401 Unauthorized

But if I do the same outside of the container, then it works and can pull down the EE dependencies, so it is a problem with my local environment.

Problem solved.

I am using the (VSC Remote Development plugin) so I can perform all the development inside a Docker container. Specifically, I needed to add the following entry in my devcontainer.json file to copy my settings.xml file, which contains my Camunda EE credentials, to the home .m2 directory inside the container where Maven is pointed to.

"postCreateCommand": "mkdir ~/.m2 && cp .m2/settings.xml ~/.m2/settings.xml"

Hi @Justin_Phillips

Thanks a lot for posting the solution to the problems you where having, i’m sure this will help people out if they’re having the same issue.

1 Like