Cannot build Java Project (eclipse) because of test error

I tried to assign a Service Task with a Java Class. The problem is that I can’t build the project in Eclipse because of a UnitTest Error. Because I’m new to Camunda I tried to follow the Camunda-Tutorial (Tutorial: Camunda Enterprise Edition for Java Developers (Video 2) - YouTube) and I did exactly the same but I get a Process Unit Test error. The problem seems to be here:

@Deployment(resources = “process.bpmn”)
public void testHappyPath() {
// Drive the process by API and assert correct behavior by camunda-bpm-assert

ProcessInstance processInstance = processEngine().getRuntimeService()



Is there a way to ignore the test (I tried to delete it but that doesn’t work) or does anybody know a solution? Thank you!

Hi @Michael_Ko,

What error message do you get in the test? I would recommend that you fix the test and then run the application.


1 Like

Thanks for the reply. I’m sorry it was a typo from my side. So I think you can delete this post!

1 Like