Can't find Service Task or Intermediate Timer Event in the Zeebe Modeler

Hi
Getting Started – Can’t get it to work. The Modeler is not functioning as expected on Windows 10. See below.
See Getting Started :Create Workflow Tutorial second step.
That what I see - From Zeebe Modeler on Winodows 10 , It is windows-64 download .
The Modeler is not functioning as Zeebe expect.There missing elments , no message event, no type field in properties panel etc.

Hi @rubi,

Please have a look in the documentation how to use the modeler: https://docs.zeebe.io/bpmn-workflows/service-tasks/service-tasks.html#additional-resources

In the BPMN section under additional resources, you can find some videos how to use the modeler.

Does this help you?

Best regards,
Philipp

The modeler gui is not the same as in the docs videos.
It seems that it is not the same product (missing core elements) it is not personal usability problem.You can download the windows zip and find the problem.Thanks.

Found out that there is no correlation between the docs-videos and the modeler. Selecting the right type on the wrench icon every step is needed.

Thanks.

@rubi it feels like you are comparing the Camunda Modeler and the Zeebe Modeler… The Zeebe Modeler has just a subset of BPMN elements compared to the Camunda Modeler. The Zeebe project will add support for more elements in the future, but due to the Cloud Native nature of Zeebe, not all the BPMN elements are supported in the current version.

1 Like

What version of the modeler is this? On Mac with 0.7.0-alpha.2 it looks like this for me:

1 Like

Hi Guys,

I have the same problem on my side on windows 10.
The Zeebe Modeler is different from the one shown in the tutorial.
Any idea how I can get all the tasks types to appear?

Thanks for your help!

It seems to be a problem (or a characteristic) of the latest 0.8.0 version, I got the version 0.7.0-alpha.2 and it has the same tasks mentioned in the tutorial.

Same for me. I was looking for Timer Event and got desperate after I couldn’t find the symbol in the palette of the latest Zeebe Modeler 0.8.0. Then I tried the latest Camunda Modeler 3.7.1 (just for curiosity) - but also there event symbols are missing. Only after finding this post I tried with Zeebe Modeler 0.7.0 and voila! - the event symbols are there.

Now I’m just wondering why Camunda Modeler 3.7.1 has the same issue. Could it be a common bug?

@phileas74 @lucasledesma can you please share which tutorial are you referring to ?
Not all BPMN symbols are currently supported in Zeebe, so comparing with Camunda Modeler will be always a sub set.

@salaboy the tutorial is the getting started one
https://docs.zeebe.io/getting-started/create-a-workflow.html

I also tried latest Camunda Modeler and it was the same as the latest Zebee Modeler, maybe in the latest version tasks types are no longer supported? Just some thoughts… anyway, I was able to follow the tutorial by installing a previous zebee modeler version --> 0.7.0-alpha.2

@lucasledesma good to know… I will investigate more on this.

Click the little spanner / wrench icon and choose “Service Task”

I opened this issue: https://github.com/zeebe-io/zeebe-modeler/issues/204

I hadn’t noticed the wrench there !
Thanks @jwulf !

1 Like

OMG, the wrench icon offers it all!

zeebe_modeler_0.8_intermediate-boundary_event

Thanks @jwulf

2 Likes

I was referring to the Zeebe Documentation at https://docs.zeebe.io

For instance, in chapter 4.6.3. Timer Events, paragraph “Additional Resources” > “Using the BPMN modeler” there is a video tutorial that seems to refer to a previous Zeebe Modeler version, which offers the Timer Event in the pallette.

1 Like

I opened a bug about this: https://github.com/zeebe-io/zeebe/issues/4293

1 Like