Closed Post


when start Camunda modeler v. 5.0.0 I get the following error and the model will not be shown. Can anybody help?

Thanks in advance

Can you post your model (.bpmn file)?
It looks like your XML might have been modified outside Camunda and the unique identifier for one of your activities was duplicated.

unfortunately I can’t see the model and get the same error when i start the model in v. 5.0.0.
with v. 4.12.0 it works fine

Okay i see. maybe its a problem with v. 5.0.0?

I’m thinking that it doesn’t like the number of child lanes that are created.
Unfortunately, I don’t have access to Modeler 5.0 here… only 4.9

Was it the exact same error (about activity_0evu504 ) or did the activity ID that it is complaining about change?

It is complaining about the same activity:

\Mayer Fabrik_SOLL_2.bpmn] element <Activity_0evu504> already exists

On the official website of camunda i only have acces to v. 5.0.0 as the latest version

Deleted posts, since the links were still active in the edit history.

At the end of the XML, there were a bunch of extra DI elements:

  <bpmndi:BPMNDiagram id="BPMNDiagram_1x3wolx">
    <bpmndi:BPMNPlane id="BPMNPlane_15u2g9j" />
  <bpmndi:BPMNDiagram id="BPMNDiagram_1bp0aj3">
    <bpmndi:BPMNPlane id="BPMNPlane_1i87nay" bpmnElement="Activity_0evu504" />
  <bpmndi:BPMNDiagram id="BPMNDiagram_12sk3gb">
    <bpmndi:BPMNPlane id="BPMNPlane_17kloyh" bpmnElement="Activity_00xhr2d" />
  <bpmndi:BPMNDiagram id="BPMNDiagram_1dwetih">
    <bpmndi:BPMNPlane id="BPMNPlane_0uh12d7" bpmnElement="Activity_1a9bf7c" />
  <bpmndi:BPMNDiagram id="BPMNDiagram_0hoyp8z">
    <bpmndi:BPMNPlane id="BPMNPlane_0076kao" bpmnElement="Activity_036k3w0" />

I simply removed them from the XML and resaved the file. The Activity_0evu504 that Modeler was complaining about was in one of those DI elements, but was already on the canvas, so it couldn’t add it again.

1 Like

Thank you very much for your help! :slight_smile: