Cockpit is not showing latest changes

Hi Camunda Team,

We have tried creating a sample flow and deployed the same on Tomcat by building the war .

The Cockpit is not showing the BPMN diagram.

Can anyone help on the same.?

Can you post up the Model itself?

SwiftPayment.bpmn (2.9 KB)

attaching BPMN model

Thanks for checking this Niall

These are the steps i followed:

  1. created a bpmn diagram in camunda modeler.
  2. Saved the diagram under Eclipse → SRC ->main → resources folder.
  3. Run Pom.xml as maven install.
  4. Took the new war from maven folder and deployed in tomcat web apps folder.

Attacheing war file by renaming extention to .txt. Rename to war and extract.

loan-approval-0.0.1-SNAPSHOT.txt (5.5 KB)


Your diagram is not valid so the eclipse is not able to upload your diagram. The Consume SWIFT notation is not set. You need to define a type of the notation such as Script task, (see the attached example)

Regards: Gábor
SwiftPayment.bpmn (3.0 KB)

1 Like

Hi Gabor,

I tried the file you shared.

  • Added to the resources folder under eclipse.
  • On pom.xml we performed a maven build.
  • Copied the generated WAR to webapps folder.
  • Started the tomcat.

We still don’t see the Diagram reflecting in cockpit.

Hi @aqaadi,

It seems that the location of the processes.xml is not correct. The processes.xml should added to src/main/resources/META-INF folder 1.


1 Like

Hi @aqaadi,

Did you also add the processes.xml into the META-INF folder? Could you please share your resulting WAR file?


Hi Roman,

yes we have added the META-INF with processes.xml.

Attaching the war.payments-system-0.0.1-SNAPSHOT.txt (4.7 KB)

Please rename the file type from TXT to WAR .


Did you get a chance to look into this ?

Please be more patient. This is a free offering and sometimes people have more important things to do. Roman will surely get back to you.

I totally understand.

Thanks for all support.

Hi @aqaadi,

Does your process application class look as follows? Please note the @ProcessApplication annotation 1.

public class PaymentsSystemApplication extends ServletProcessApplication {


If it still does not work, could please share your entire project?


Annotations were missing .

I can see my process instances now.

Thanks Roman !!