Deployment successful but the process is not in Cockpit

I am a newbie to Camunda. I am in a small french StartUp that is modeling his processes (~50).
I have watched all the (excellent) videos from Niall and I have a pretty good knowledge of BPMN.
I am trying to execute some of these processes with the Camunda engine (CE version).
I don’t succeed to deploy my first process.
I have no deploy button in Cockpit/Deployment screen (as in the first video)
I tried the “Deploy current diagram” in Camunda Modeler entering a Deployment name (that I set to the process name) I let Tenant Id to null. I get the green Success message but my process is not present in the Cockpit/Deployment list.
I let the Endpoint URL to http://localhost:8080/engine-rest/deployment/create (that is not accessible from the Web browser)
I use the latest Camunda engine from docker on a Mac (I didn’t succeed to start the local engine using the shell script)
Any idea of what should I do ?

Side questions

  • How to create only one lane ?
    when I drag and drop a pool in the modeler it seems to me that there is no lane created. The workaround I found id to add a lane under or above (then I got 2 lanes) and name one and suppress the other

  • How to access a subprocess from the diagram ?
    I have read that it is by Ctrl-click on Windows but I am on a Mac and Cmd-click do not work

  • Inclusive gateway what if no condition to true ?
    If no condition is true on the branches of a Inclusive Gateway does the token goes to the “end of Inclusive gateway” (as I cannot deploy my processes I cannot test this at the moment !) ?

Thank you in advance

Can you upload your process model - i can take a look at it and see if there is any issue with it

Contenu court speakUp1.bpmn (17.3 KB)
I already sent it to you by email.
Perhaps it’s better here

Hi Carella,

So the main problem seems to be that you haven’t any added any execution semantics to the model. e.g. expressions for gateways or timer settings.

The modeler has a little bug at the moment where it tells you it’s successfully deploy when it hasn’t, which might explain the confusion.

In answer to your other questions:

  • Lanes: I’m pretty sure lanes only exist if you need at least 2 - otherwise it’s just a pool and the concept of a lane isn’t require. Also - lanes aren’t really needed by the engine, they’re only a visual indicator so i suggest only using them if you have to
  • The feature to go from a Call Activity to the process model it calls is not available in the desktop modeler but it is available on our web modeler
  • At least one sequence flow must be true or there will be an error. To ensure this you can use a default flow - which would be activated if no other branch matches.

Maybe just a dumb answer, but I had similar situation while deploying a model without a name from modeler. Setting the name fixed it.

EDITED: I mean process name …


1 Like

Thanks for all
I’ll try to check and fix this

I’m following the example from “Get Started > Executable Process > Deploy the Process” and I’m having the same problem. As far as I can tell, I entered everything exactly as shown in the pictures for the model. Could there be something missing in the example?

could you upload your model?

payment.bpmn (2.5 KB)

From your model, Implementation is missing for service task.

Yep, I missed a step. Thanks. I kept thinking I followed it exactly.