Error Class telemetry

When starting Camunda 15, it starts correctly, but when starting the REST service we get the following error

java.lang.NoClassDefFoundError: org/camunda/bpm/engine/impl/telemetry/PlatformTelemetryRegistry

Umm, that seems really odd.
can you explain a little more about which distribution of Camunda you’re running and how you’re starting Camunda?

We are installing camunda WAR files ( as we always have ) - camunda-engine-rest-7.15.0.war(from maven), camunda-webapp-tomcat-standalone-7.15.0.war (from camunda).
Operatins systems is Ubuntu 18.04 server, tomcat version is 9.0.16.
We tried to fix the error adding to applicationContext.xml the 2 lines below, and disabling telemetry on Admin, but no results with neither of these actions

Finally today we tried version 7.14, but same error. Last version we had working was 7.11, but schemas are not uploadable anymore, thats why we need to make the upgrade.


Interested in knowing how this issue was resolved. We are having the same issue on deploying 7.15.11 version of camunda rest engine on wildfly version 20. Any advice?

Caused by: java.lang.NoClassDefFoundError: org/camunda/bpm/engine/impl/telemetry/PlatformTelemetryRegistry
    Caused by: java.lang.ClassNotFoundException: org.camunda.bpm.engine.impl.telemetry.PlatformTelemetryRegistry

Hi - can someone pls respond on how to resolve the error? We are trying to install 7.17.3, we have been running 7.13.2 without issues, but we are also facing the same exception related to PlatformTelemetryRegistry. Any hint would be appreciated.

This problem can occur when someone alters the content of a camunda war file but doesn’t repackage it back correctly. Double check your META-INF folder, especially the MANIFEST.MF file which describes the modules dependencies’. If this is either missing or has missing dependencies then the module will be loaded before it’s dependencies and fail with NoClassDefFoundError .