Error: deploy diagram


I am learning from the beginning and following the tutorial: Quick Start.

I have met a problem while I am trying to deploy the diagram in Camunda. It shows “Error: request to HTTP://localhost:8080/engine-rest/deployment/create failed, reason: connect ECONNREFUSED”. The eclipse side is running, I think, though the console keeps printing error messages:
ERROR org.camunda.bpm.client - TASK/CLIENT-03001 Exception while fetch and lock task.
org.camunda.bpm.client.impl.EngineClientException: TASK/CLIENT-02002 Exception while establishing connection for request ‘POST http://localhost:8080/engine-rest/external-task/fetchAndLock HTTP/1.1’

Caused by: org.apache.http.conn.HttpHostConnectException: Connect to localhost:8080 [localhost/, localhost/0:0:0:0:0:0:0:1] failed: Connection refused: connect

I do not know if this influences the deployment, but I paste the errors here anyway.

It will be really appreciated if someone could answer me. :slight_smile:

Do you have the Camunda Platform running locally when you try to deploy?

Yes, Camunda is running on my Windows laptop, and I also tried to deploy my diagram on it, while Eclipse is also running the java program.

Can you explain exactly how you’re deploying the process and upload your model as well?

Hi, I just followed the instruction in Quick Start tutorial, created the diagram, and a Maven project in Eclipse, ran the java code, and clicked the “deploy” button in Camunda graphic interface. Nothing special actually.

Your problem might be that the depolyment method you’re using is incorrect.
You can only really deploy a process via the modeler if you don’t need any java classes (e.g. you’re using external tasks) otherwise you need to build the project with maven and deploy the war file to the application server.

Thanks a lot! I will have a try, but I actually just followed the tutorial, step by step… I have no idea of how to deploy the jar file (you wrote war file, but you meant jar, right?) to the application server.

which tutorial did you follow exactly?

Hi, this is the link of the tutorial:

Maybe try to follow this tutorial if you want to deploy a process:

1 Like

Great, Thx a lot! I will try and let you know the result.

Hi, the problem is solved, thank you.

1 Like