Execution waiting at Start Event

Hi All,

When I start my process instance , the execution is waiting at start event (the history doesn’t even show that the execution travelled further the start event).It was working fine and all of a sudden it started. I checked the standalone servers logs and cant find any exceptions. Earlier the system had some dead lock issues ( Deadlock when completing external task) and I restarted the server and the issue still persists. Can someone help me where I should start my investigation.



Process instances again started stuck at the start event once I start the instance. From the Catalina logs I could see there are two issues.

1.13-Feb-2021 11:29:55.065 SEVERE [http-nio-8080-exec-7] org.jboss.resteasy.logging.impl.Slf4jLogger.error failed to execute
javax.ws.rs.NotFoundException: Could not find resource for full path: http://host-ip:8080/engine-rest/
at org.jboss.resteasy.core.registry.SegmentNode.match(SegmentNode.java:112)

  1. 13-Feb-2021 11:29:55.721 SEVERE [http-nio-8080-exec-5] org.jboss.resteasy.logging.impl.Slf4jLogger.error failed to execute
    javax.ws.rs.NotAllowedException: No resource method found for GET, return 405 with Allow header

However, I even tried to hit http://host-ip:8080/engine-rest/deployment , this returns 200 with the list of deployments. Sometimes a re-deployment may fix this issue, but cant afford to have deployment all the time.

Could someone please help me out.

Hi @prasadps,

It’s not clear to me if you managed to resolve your previous deadlock issue or not. Can you clarify if you managed to resolve it first? If you managed to resolve that issue, it would be useful if you confirm it in that thread, and (if possible) mark a comment as the solution there.


Hi @nikola.koevski ,

Thank you so much for your response.

This issue is not yet resolved. It happens when the server is restarted. A re-deployment solves the issue. I am dead in the water.

Thanks and Regards,

@prasadps, I would recommend to try and resolve the deadlock issue first, as it seems they might be related. If the issue described in this topic is still present after resolving the deadlock, we can continue.


Hi @nikola.koevski,

After changing the environment , deadlock issue again popped up after a long time with the following error.

Cause: com.microsoft.sqlserver.jdbc.SQLServerException: Transaction (Process ID 80) was deadlocked on lock resources with another process and has been chosen as the deadlock victim. Rerun the transaction.(We are using MS SQL Server)

I could see the below solution in Camunda Docs.


However our camunda tables lies in the same database as to that of another application. So the above mentioned changes will affect those tables as well. Is there anyway I can apply those mentioned changes in camunda server config.( ie inside Resource tag.) as an alternative.

<Resource name=“jdbc/ProcessEngine”

maxIdle=“20” />


I had a problem long time ago, that on restart of server job executor did not work and after redeployment of models it agains worked, until next camunda restart.

I solved it with

<property name="jobExecutorDeploymentAware">false</property>

But this can cause other problems if you have several process applications with different process models (and code) working with the same camunda DB.

I am using several camunda engines with 1 shared db with this option also.

I will try this option. I have a standalone Camunda Server with only one node. So it is not a matter of concern.

If the apps contain different processes then I wonder how it can work.