Failed to bind properties Error

Hi, I upgrade from zeebe 0.2 to Zeebe 1.
I’m getting following error.

Failed to bind properties under ‘zeebe.client’ to

Reason: io.grpc.ClientInterceptor

pom.xml included

io.camunda zeebe-bom 1.1.1 import pom io.camunda spring-zeebe-starter 1.1.0

External Libraries includes:

Hey @Dulanjali

as you can read in the docs:

Please be aware that the major version update from 0.26 to 1.0 is not backwards compatible. Therefore data cannot be migrated from 0.26 to 1.0 and client applications have to be adjusted to the new API versions.

Please follow the upgrade guide:

If you have more questions post them here.


Hi @Zelldon

Thank you for the reply. Actually I’m little new to Zeebe and Camunda.

There wasn’t any kind of data migration. I upgraded only my Java springboot application which was using zeebe as dependencies. Inside the devolopment I changed required methods as per version change.

I tried this setup in java 8 and 11 both. In both case got the same error.

When I do version upgrade using maven dependencies is there any specific cache/folder I need to clear?

Naive suggestion: delete .m2 cache?