Getting "SAXException" while deploying bpmn file in "zeebe simple monitor"

Getting below “SAXException” while deploying bpmn file

Error: Command rejected with code ‘CREATE’: Expected to deploy new resources, but encountered the following errors: ‘multijobprocess.bpmn’: SAXException while parsing input stream

Could you please help me.


No. In order to get any help, you need to provide all information that helps to analyze the issue and to reproduce it.

In this case, you should provide

  • the full log that contains the failure
  • the BPMN file
  • your environment (i.e. how you setup Zeebe and the Simple Monitor - including the versions)

@philipp.ossler i have redesigned bpmn and successfully deployed it in zeebe simple monitor.
zeebe simple monitor and broker are running on linux server using docker-compose.yml

Normally bpmn file have xml view also,there we can find sequence/message flow and gateway related(<bpmndi:BPMNShape id=“ExclusiveGateway_13nw957_di”> , <bpmndi:BPMNEdge id=“SequenceFlow_10m4qko_di” bpmnElement=“SequenceFlow_10m4qko”> )
exactly here i have faced issue.After redesigning bpmn file it got resolved.


I run into the same problem. The exact message is:
Error in Deploy WorkFlow: Server error “3” with message: Command rejected with code ‘CREATE’: Expected to deploy new resources, but encountered the following errors:%0A’C:\SYCON\SDX3T\ProCoMon\Win32\Debug\MIN_EXTR3.bpmn’: SAXException while parsing input stream

I’m using:
zeebe-0.23.1 / ZeeBe Modeler: with docker compose in “operate-simple-monitor”

The error occurs whenever the BPMN file exceeds a, as if feel, moderate complexity. I’m not allowed to publish the BPMN-File in a public forum but can give it to someone when needed.
Txs for any help,

Hi @PeterMM,

please share your BPMN file, for example, via GitHub repo/gist.

Does this also happen with other BPMN workflows?

Best regards,

Yes, seems to happen all the time when the complexity growth.
You can find an example BPMN file here:

I’ve just found out that the problem only occurs, when the BPMN-File is deployed via gRPC API. Deploying from ZeeBe-Modeler is OK.
I’m using my own client, so maybe that client is the problem. Some one around to verify?

Hi @PeterMM,

I tried to reproduce the behavior and deployed the BPMN via Zeebe Simple Monitor. This works for me without error.

However, the BPMN is not migrated to Zeebe 0.23.0 yet. So, the deployment is rejected. But it’s working with version 0.22.1.

Please share the whole log that contains the failure.

Which client do you use?

Txs Philipp,

I’m using my own (delphi written) client and it seems, that the problem is coming from the gRPC lib used. At least that is what the gRPC dump looks like…The raw_message deployed by “DeployWorkflow” is corrupted :frowning:

What “whole log file” are you asking for?

Hey @PeterMM,

that sounds interesting. Could you try to reproduce it with a official supported client, like go or java? Would be nice if you can share the example then so we can reproduce and have a deeper look at it.


The ZeeBe CLI and also the ZeeBe-Modeller can deploy the BPMN file successful.

The problem occurs, when the size of BPMN-file exceeds 16.834 bytes, the chunk size of the used NTTP2 Lib. So I think my client is the problem :frowning:

Txs your help so far

Hi all, I had the same issue and error message, but I could solve in a different way.

First of all, I wrote my diagram with the Zeebe modeler (version and everything was OK.
I could deploy the diagram to the Camunda Cloud (Zeebe on the cloud beta program).

Then, I made some little adjustments to the diagram and because it presented some errors, I re-wrote it with the same symbols and properties, but it began to present the same error you mentioned before “SAXException”.

Then, I closed the diagram and opened it again from the Zeebe Modeler and it throw the following warning: “unknown attributes ‘bounds’ [warning]”.

I searched this attribute in the XML and I found to which element it belonged.

I deleted the element and recreated it.

Since then, everything went OK.

Hope it helps you.


1 Like