History not clean

Hello!
bpm-platform.xml:

Summary

“history”>none
“databaseSchemaUpdate”>true
“authorizationEnabled”>true
“jobExecutorDeploymentAware”>true
“jobExecutorActivate”>true
“historyCleanupBatchWindowStartTime”>00:01
“historyCleanupBatchWindowEndTime”>23:59
“historyCleanupBatchSize”>500
“historyCleanupBatchThreshold”>0


Where and how can you see the errors that arise when cleaning history?
All parameters are set, data is not cleared.

The ACT_HI_JOB_log is empty …

Hi @ntdim1973,

you have no history enabled.

This means: no history events are fired.

That is the reason why the ACT_HI_JOB_log is empty.

Is your question answered?

Cheers
kristin

1 Like

The maintenance of the history was previously included and was disabled later.
Now I want to start cleaning up this historical data, but this does not happen …

Hi @ntdim1973,

I’m not sure whether I understand you correct.
It is right, you want to clean up the existing history entries because you don’t need some history?

You can try to clean up the history manual. You can find more details in our documentation:
https://docs.camunda.org/manual/7.7/user-guide/process-engine/history/#manual-run

Cheers
kristin

1 Like

Yes exactly.
I used it, but cleaning does not happen …

Could you please provide the stacktrace which you got.

Hi @ntdim1973,

did you define “history time to live” on process definitions, for which history must be cleaned up?

Also, you can check the metrics, if they are enabled. History cleanup job will report there, if anything was deleted.

No, “history time to live” it was not determined.
Is there any default value? How can I get it?

Please check here: https://docs.camunda.org/manual/7.7/user-guide/process-engine/history/#history-time-to-live

Default value is null, which means that no history data will be removed.