Integrate feel-engine in spring-boot in 7.17


I run a spring-boot embedded camunda engine in version 7.17.
In one case I get a String that I have to convert to a number to check this against another variable in a decision of a gateway. After short searching I found the solution to convert the string to a number by feel. Now I wrote the following expression:

${number(VAR1) < number(VAR2)}

When I start the application I get the following error:

Caused by: org.camunda.bpm.engine.impl.javax.el.ELException: Could not resolve function 'number'
	at org.camunda.bpm.engine.impl.juel.Tree.bind(
	at org.camunda.bpm.engine.impl.juel.TreeValueExpression.<init>(
	at org.camunda.bpm.engine.impl.juel.ExpressionFactoryImpl.createValueExpression(

I tried serveral ways to include the dependency to the feel engine (in my mind this could be the issue) but I don´t get it working. I tried to add the feel-engine by adding the following dependencies:


On startup on the engine i see the following informations in the log

2023-03-24 11:43:55.487;SID:;RID:;INFO ;org.camunda.bpm.dmn.feel.scala;FEEL/SCALA-01001 Spin value mapper detected
2023-03-24 11:43:55.574;SID:;RID:;INFO ;org.camunda.feel.FeelEngine;Engine created. [value-mapper: CompositeValueMapper(List(org.camunda.feel.impl.JavaValueMapper@31620971, org.camunda.spin.plugin.impl.feel.integration.SpinValueMapper@794cd751)), function-provider: org.camunda.bpm.dmn.feel.impl.scala.function

Can anybody give me a hint to fix that issue?

Thanks for helping :slight_smile:

Hi @Thomas_Schiffler and welcome to the community,

Camunda 7s expression language is JUEL and not FEEL.
You can use FEEL for scripts and inside DMN but not for general expressions. To resolve the error, I recommend using a script:

1 Like