Ldap Groups not showing up


We have a AD Proxy setup that helps us authenticate users on an AD and OpenLDAP instance. I’m trying to get the Group details to Camunda, but it just doesn’t show up on the Groups tab of the Admin page.


For testing, I got a custom attribute mapped from the Proxy called “AuthDomain” which have the value AD or OLDP. I tried assigning this to the groupMemberAttribute but it does not display. For verification, I tried mapping this to the userLastnameAttribute and the value is displayed correctly.

What might be the reason that the value does not show under Admin-> Groups (List of Groups)?

Hello @etp,

This is my approach that I am using locally and it’s working out fine.

This is my bpm-platform.xml

Notice my group property settings. These are the search parameters for Camunda to use and find your groups. groupMemberAttribute is how Camunda will search members of the given group but not the actual group.

As per my LDAP server I have the following group example and settings.

This is the end result when I visit my admin page.

Please let me know if you have any questions.