Little Typo on method name DeploymentQuery.orderByDeploymenTime()


Using api I noticed that the method has probably a typo in the name:

shouldn’t be orderByDeploymentTime() ?

1 Like

Hi Michele,

Good catch. The thing is we can’t simply rename the method as that would break public API. One option is to add a second, correctly spelled method and deprecate the existing one. I personally think this effort is not worth it, but feel free to raise a JIRA issue and/or contribute this.


Thanks. I filed an issue in JIRA anyway.

Thats really funny. The “typo” also exists in the Activiti codebase. I guess it’s been around since before Camunda forked Activiti.