Missing Deploy Button

I recently watched the Camunda BPM Basics. During the video, it showed how to deploy a bpm from cockpit using the “Deploy” button. Is the “Deploy” button only available in the enterprise edition?

The deployment button only appears in the enterprise edition - but you can get the same affect by using this REST call directly.

edit: It’s even easier now because the latest version of the modeler has a deploy button:


edit: It’s even easier now because the latest version of the modeler has a deploy button:

Which version are you talking about ? I have just downloaded and installed camunda and I dont see any deploy button. Thanks

It’s part of the modeler. Download The Camunda BPMN / DMN Process Modeler | Camunda

so still only part of the enterprise platform- not the community platform ?

No, it’s part of the open source version - you should see it if you download the modeler. There is no enterprise version of the modeler. It’s entirely an open source project.

No it is not? This is version 4.9.0 win64.

Found it! You moved it to the status line at the bottom :slight_smile:

(But is it logical to have actions in status line? I think not…)


1 Like

HI @Hakon_Ingvaldsen

Sorry for the confusion about the button (you weren’t the only one) :slight_smile:

Moving this is just the first step is a more complete redesign, where we’ll be separating functionality in a more sensible way, right now there isn’t really any “rule” about where you might find certain functionality. In the next iterations it’ll start to make a lot more sense

I am running MacOs version 4.11. Clicking the deploy button in the status bar just gives me a file save dialog. I have no option to deploy using rest. Any ideas?

Also in the status bar there is the “Camunda Platform” when modelling a BPMN process. Clicking it show a “This diagram is supposed to be executed on Camunda Platform”

EDIT: Ok, PEBKAC. The save dialog ensures that it is saved locally before upload. Once saved the rest upload appears. Apologies, perhaps someone can learn from my stupidity. :wink: