Process Engine's Docker image crashes with Podman 3


I’m trying to launch Process Engine’s Docker image with Podman 3.0.0, but it doesn’t came up successfully.

My steps:

$ sudo aptitude install podman
Die folgenden NEUEN Pakete werden zusätzlich installiert:
  catatonit{a} conmon{a} containernetworking-plugins{a} containers-common{a} crun{a} fuse-overlayfs{a} podman podman-plugins{a} slirp4netns{a} uidmap{a}

$ podman --version
podman version 3.0.0

$ podman pull camunda/camunda-bpm-platform:latest
Resolved "camunda/camunda-bpm-platform" as an alias (/home/[...]/.config/.cache/containers/short-name-aliases.conf)
Trying to pull
Getting image source signatures
Copying blob 21c83c524219 done  
Copying blob a7362060565d done  
Copying blob 62e42f44aefe done  
Copying blob dbfd53b38a1d done  
Copying config fa28e3fe7b done  
Writing manifest to image destination
Storing signatures

$ podman run --name camunda --publish 9090:8080 camunda/camunda-bpm-platform:latest 
Configure database
18-Feb-2021 11:05:12.626 INFO [main] org.apache.catalina.startup.Catalina.load Server initialization in [840] milliseconds
18-Feb-2021 11:05:14.019 SEVERE [main] org.apache.tomcat.jdbc.pool.ConnectionPool.init Unable 
to create initial connections of pool.
org.h2.jdbc.JdbcSQLException: Error while creating file "/camunda/camunda-h2-dbs" [90062-190]
	at org.h2.message.DbException.getJdbcSQLException(
	at org.h2.message.DbException.get(
	at org.h2.message.DbException.get(
	at java.base/java.lang.reflect.Method.invoke(
	at org.apache.catalina.startup.Bootstrap.start(
	at org.apache.catalina.startup.Bootstrap.main(

What went wrong here? Seems there is something missing in the Docker image, some file system path for H2 database.



FYI: I’ve also tried Docker image version 7.15.0-alpha2 and 7.15.0-alpha3 (instead of latest) with same result.

Good morning,

sorry for all thas noise: This morning an update of Podman to version 3.0.1 makes the problem disappear.


1 Like

Thanks for letting us know you found a solution :slight_smile: