Report download from camunda optimize

Hi Team,
Having issue while downloading report from camunda optimize. Can anyone help me out?
“errorCode” : “serverError”,
“errorMessage” : “An internal server error occurred.”,
“detailedMessage” : “Could not evaluate ProcessViewRawData ProcessGroupByNone ProcessDistributedByNone report for definition with key [Process] and versions [[all]]”,
“reportDefinition” : null

Hi @Hariharan,

When you say downloading the report, do you mean exporting the actual report (via the “export” button) or downloading the result of the report as csv (using “download csv”)?
Also, can you open and evaluate the report within the Optimize UI or are you getting the same error there?

Hi @Helene ,
We tried to download using download.csv option.
Also after creating the report, we are able to view the data in UI, when trying to download getting the error.
Note - we got the error, when we tried to download one month data that proceed in the process, So we tried for one day, it worked fine. JFYI.
We are not able to download it for one month.

Hi @Helene and Team,
Can any of you pls help me to sort this out? :slightly_smiling_face:

Since I am not able download the report for one moth, I am doing it for each single day. It is literally killing my time :sob:

Hi @Hariharan

Before @Helene gets back to you i wanted to find out if you have an Enterprise License and if you’ve created a support ticket for this issue?

Hi @Hariharan,

To export the report results, Optimize first attempts to evaluate the report for the selected date range (1 month in this case). If you have a lot of data, it is possible that there are too many data points for Optimize/Elasticsearch to handle, resulting in the error you’re observing.

We are actually currently already working on implementing a solution to this kind of issue by adding a new JSON export API which allows you to retrieve large amounts of data. We are planning on including this feature in our upcoming Optimize release in January and you can get a sneak peek at the planned endpoint details in our documentation here. Please note that these endpoint details may be subject to change in the future.
If you would prefer not to wait, you can already test the feature in our latest alpha release(3.7.0-alpha2), though please note that alpha versions are generally not suitable for production environments.
In either case, please make sure to follow our migration guide when upgrading to the next Optimize version.

As Niall already mentioned, if you have a license and if the above does not resolve your issue please feel free to create a support ticket so we can look into your issue in more detail :slight_smile: