Running camunda docker image on RHEL OpenShift platform


I want to run the camunda docker image on RHEL OpenShift platform however, it requests that I configure the database.

[user]# oc logs pod/camunda-bpm-platform-1-9rjbk

Configure database
failed to load external entity “/camunda/conf/server.xml”

Well, you’re going to need to have to do one of three things:

  • Live with just the in-memory H2 database and risk losing data if the container crashes

  • Connect to a standard, external database instance

  • Configure docker to provide a persistent storage volume somewhere and then either add a database like MySQL to the container, or configure the H2 database to use local persistence.

I have never done any of the above as I don’t run Camunda in docker. But folks I work with are running it in Kubernetes using SpringBoot, etc., etc., etc. and these are the options we arrived at for them. They chose to connect to a standalone external database.

Hi, I’ve not done this but actually I’m planning to do something similar on kubernetes, I would add:

  • a 4th option to the ones mentioned which consists in deploying a database in the kubernetes cluster and to configure the engine to use this DB

I’ve not tried it yet but will do (hopefully soon) and will keep you informed, I’m obviously also interested in any similar experiences

See my question here : Building resilient cloud native app with Camunda and K8S

Did you manage to fix it? I am getting the same error.

Yes I did it on Kubernetes deploying several pods

  • one with a mysql db
  • one with camunda engine embedded in a SpringBoot app
  • and one with camunda standalone-app (cockpit-tasklist-admin)

Off-course I’m saying one for each here but in reality, I meant set of pods: a mysql (master + slave pods ), several camunda engine and several camunda stand-alone app.

I was able to deploy a container on a kubernetes cluster as well, but getting the same error when trying to deploy it in openshift. Anybody was able to deploy camunda on openshift?

Configure database
failed to load external entity “/camunda/conf/server.xml”

I had some problem with camunda deploing on OpenShift cluster and found solution.
Camunda image needs to run as the root user. By default, OpenShift won’t allow it to run as root but you can enable it by adding the permissions.
See detail in answer here:


i solved permission issues with the following extended image:

FROM camunda/camunda-bpm-platform:tomcat-latest
USER root
RUN chgrp -R 0 /camunda
&& chmod -R 774 /camunda
USER camunda