Serialization / Process Variables in Camunda 7.15

Hi all

I upgraded my Spring Boot Camunda application from 7.14 to 7.15 yesterday. (Spring Boot Version 2.4.5). I’m using the Camunda Java API (not REST)

It’s a very simple process which worked fine until 7.14

I’m adding a variable (JPA Entity) as process variable and the process gets started. Next step in the process is a human task. When I try complete the human task in the Tasklist i receive the following error:

An error happened while submitting the task form : class ch.bfh.ti.vmprovisioner.model.VMOrder cannot be cast to class ch.bfh.ti.vmprovisioner.model.VMOrder (ch.bfh.ti.vmprovisioner.model.VMOrder is in unnamed module of loader ‘app’; ch.bfh.ti.vmprovisioner.model.VMOrder is in unnamed module of loader org.springframework.boot.devtools.restart.classloader.RestartClassLoader @1c20d5d9)

I also tried to add a much simpler variable (POJO which implements Serializable), with the same result.

Sorry, for providing so little (additional) information, as I tried so many things, I’m absolutely clueless.
And as mentionend: Everything worked as expected with 7.14

Also: I’m not sure, if this is the correct category for this question …

Any help is much appreciated!
Kind regards

Sorry, meanwhile I have doubts if this is related to Camunda (7.15) anyhow …

Hello Thomas,

How did you start the application?
I would expect that you run it in your IDE or with enabled spring boot developer tools, right? If that’s the case, please try to execute your application via jar and check if the issue is reproducible or disable explicitly the developer tools (1).
I think you stabled upon on the following issue CAM-9043, which is not related to the new 7.15 release but to how the spring boot starter is handling the classloading when the developer tools are enabled.

(1): Using Spring Boot

Hope that helps.

Best regards,

Hello Yana,

Thank you for your help!

Yes, exactly: From IDE with Spring DevTools enabled.

I think it helps! Thanks again!

Kind regards,