Stuck Broker Pod - Cannot Connect With Other Nodes

We are running zeebe 8.1.6 on aws using helm charts. Since last few days we are seeing that the broker pod does not start up and remains stuck with the below logs. It cannot connect with other members in the cluster. The config is for 2 gateways and 3 brokers - 3 partitions.We tried terminating all the ec2 instances (except the k3s master) and recreating them still the same error gets printed in the logs. This issue was observed earlier as detailed on this github issue but it was closed with some code fix.

Any thoughts on how to resolve this issue?

Broker logs

2023-03-14 12:09:42.682 [] [raft-server-0-raft-partition-partition-1] INFO
      io.atomix.raft.roles.FollowerRole - RaftServer{raft-partition-partition-1}{role=FOLLOWER} - Sending poll requests to all active members: [DefaultRaftMember{id=1, type=ACTIVE, updated=2023-03-14T12:08:55.177Z}]
2023-03-14 12:09:42.683 [] [raft-server-0-raft-partition-partition-1] WARN
      io.atomix.raft.roles.FollowerRole - RaftServer{raft-partition-partition-1}{role=FOLLOWER} - Poll request to 1 failed: Expected to send a message with subject 'raft-partition-partition-1-poll' to member '1', but member is not known. Known members are '[Member{id=0, address=c8-zeebe-0.c8-zeebe.default.svc:26502, properties={brokerInfo=EADJAAAAAwAAAAAAAwAAAAMAAAACAAAAAAABCgAAAGNvbW1hbmRBcGklAAAAYzgtemVlYmUtMC5jOC16ZWViZS5kZWZhdWx0LnN2YzoyNjUwMQUAAAwAAAUAAAA4LjEuNgUAAA==}}]'.


Ping to all the nodes work. I enabled debug logs on the zeebe broker and shared here. One of the debug log that struck me

[GatewayTopologyManager] [Broker-0-zb-actors-3] DEBUG
io.camunda.zeebe.gateway - Received metadata change from Broker 0, partitions {}, terms {} and health {}.

Looks like our networking team had blocked UDP ports which lead to this issue. We enabled UDP ports and the brokers came up