Tasklist Filter Auto-Refresh Issue


I have created a filter in the Tasklist to display all the tasks assigned to a particular user. I have checked the ‘Auto-Refresh’ option in the filter.

I notice that in many cases, the Auto-Refresh feature is not getting fired correctly, ie. after starting a task and it being assigned to my user (using #{user_Requestor}), the task does not appear in the filter. I have to click on the ‘My Task’ filter to refresh and show the task. Sometimes the task appears after around 10s.

Similarly sometimes after I have completed the task, the task seems to remain in the Tasklist menu, if you click on it, you get an error that informs the task does not exist. If you click on the filter instead, it refreshes and the task disappears.

Any suggestion on how to over come this issue is much appreciated. I use v7.11.1

Hi @etp,

the Auto-Refresh option refreshes the List of Tasks every 10 seconds… and that’s all it does. I see that a refresh after certain actions such as starting Tasks, Processes or changing Tasks can be desirable as well.

Unfortunately I don’t see an easy way to fix it on your end that does not require a custom webapp build. As you are using the EE version, you can raise a Feature Request with Support :slight_smile:

Hope this clears it up

Hi @martin.stamm,

Thanks for the update. I have created a feature request CAM-10944.

Since I assume a feature request will take it’s own time to get implemented, is there any workaround to reduce the refresh time from 10s? Probably an edit in the Tasklist UI component or edit some parameter in the engine db?

Hi @etp,

the refresh time is hard-coded here: https://github.com/camunda/camunda-bpm-webapp/blob/master/ui/tasklist/client/scripts/controller/cam-tasklist-app-ctrl.js#L70

You can also create a custom script which triggers the refresh on the root scope in intervals. This way you don’t have to build the whole webapps.

HI @martin.stamm,
I am developing a custom spring-boot webapp (based on the https://github.com/camunda-consulting/code/tree/master/snippets/springboot-customized-webapps example) and I need to change the refresh time to 120000. I tried to change the hard-coded refresh time in the cam-tasklist-app-ctrl.js
I added the modified version of the file in src/main/resources/META-INF/resources/webjars/camunda/app/tasklist/scripts/controller/cam-tasklist-app-ctrl.js, but nothing has changed. Is there a way to customize this js file in a spring-boot project?

I’m using Camunda 7.12.0 with Spring Boot 2.2.1.RELEASE

Thanks in advance,

Hey @javajunior,

The source files are bundled into one file which is then served by the application server (app/tasklist/scripts/camunda-tasklist-ui.js). You will have to replace the whole bundle in order to get the changes you desire.

The bundle is created using grunt. On the github page for the webapp, there is a guide on how to build them.

Keep in mind that creating your own tasklist in this way will introduce maintenance work when you want to upgrade to a newer version later.


1 Like

Thanks @martin.stamm for the quick reply. I had thought about this solution, but in this way I don’t have a customizable refresh interval (my idea was to use a POM property).
However, following your solution, should I create the bundle with grunt and manually copy the camunda-tasklist-ui.js to src/main/resources/META-INF/resources/webjars/camunda/app/tasklist/scripts folder?


Yes, that should work. But I’m really not that proficient with spring boot, I would have to try it out myself

If it does not work, let me know and we will find a solution :slight_smile:

1 Like

It worked! :wink:

i have the following error in both cockpit and admin console: “It looks like you’re using a minified copy of the development build of Inferno. When deploying Inferno apps to production, make sure to use the production build which skips development warnings and is faster”.
How can I build the webapp in production mode to use it in custom spring-boot webapp (https://github.com/camunda-consulting/code/tree/master/snippets/springboot-customized-webapps)?


Did you solve it?