Unable to binding floating point variable from webhook payload

Hi everyone,

Having a bit of a weird error. I’m posting an event from Salesforce to Camunda and am running into trouble binding this eeCount__c value from the payload into a process variable. It’s a strange error because I’m able to bind all of the other values from the payload. The only difference I can tell is that this eeCount__c is a float (because for some reason I can’t pass it as an int from SFDC).

Payload:

{
  "request": {
    "body": {
      "detail": {
        "payload": {
          "accountId__c": "0000xxxxx",
          "eeCount__c": 2.0
        }
      }
    },

FEEL mapping:

{
  opportunity_ees: request.body.detail.payload.eeCount__c,
  account_id: request.body.detail.payload.accountId__c
}

Here you can see my process variables, this one is not mapping at all.

I’ve tried some variations including wrapping it with number() and int(), but it still fails to map.

Any ideas? Thanks for your help

Hi @csh3
Could you please show how you’ve tried to wrap it with number()?