Unable to save or complete form

I’ve an embedded form for a receptionist to verify whether the patient is who they say they are. The problem is that the Save and Complete buttons are not responding.

I thought that this might be something to do with permissions for groups/users but I’m in the task-list as admin, so I can claim the task and check and un-check the checkbox, but I can’t seem to save or complete the form so as to move on. The HTML for the form is as follows:-

<form name="display-results">
	<div class="form-group">
		<label for="appmtTime">Appointment Time</label> <input
			class="form-control" cam-variable-type="double"
			cam-variable-name="appmtTime" name="appmtTime" readonly="true" />
	</div>
	<div class="form-group">
		<label for="patientFullName">Patient Full Name</label> <input
			class="form-control" cam-variable-type="String"
			cam-variable-name="patientFullName" name="patientFullName"
			readonly="true" />
	</div>
	<div class="form-group">
		<label for="patientFullAddress">Address</label> <input
			class="form-control" cam-variable-type="String"
			cam-variable-name="patientFullAddress" name="patientFullAddress"
			readonly="true" />
	</div>
	<div class="form-group">
		<label for="nhsNumber">NHS Number</label> <input class="form-control"
			cam-variable-type="Double" cam-variable-name="nhsNumber"
			name="nhsNumber" readonly="true" />
	</div>
	<div class="form-group">
		<label for="IS_Patient_identified">Patient Verified?</label> <input
			type="checkbox" cam-variable-name="IS_Patient_identified"
			cam-variable-type="Boolean" />
	</div>
</form>

I know that this is something really obvious but I can’t see the wood for the trees.

any help?

Anthony

Hi @theHornet
can you check if any errors are showing up in the Browser console when clicking the complete button?
Please post the errors here.
Best
Felix

Thanks for replying,… how would I check the browser console in this case?

Are you using Chrome?

Opening the Chrome DevTools
Select More Tools > Developer Tools from the Chrome Menu.
Then there should be a tab called “Console”. Try to complete the form after opening the tab “console” again. You should see some errors.

1 Like

Thanks for that, I was able to see that the process variable I had assigned earlier didn’t match the type on the form and so I wasn’t able to save/complete.

Good to hear that you were able to solve it :slight_smile: