Unable to start simple-monitor on Linux

I’m following the steps listed on

Environment being: OS - Linux , Java 11

I have tried multiple docker files, 23.1, master branch and latest and in call the cases Hazelcast is not starting up.

General exception logs being:
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'zeebeHazelcastService': Invocation of init method failed; nested exception is java.lang.IllegalStateException: Unable to connect to any cluster.

WARNING: An illegal reflective access operation has occurred
zeebe_monitor | WARNING: Illegal reflective access by com.hazelcast.internal.networking.nio.SelectorOptimizer (file:/app/libs/hazelcast-3.12.6.jar) to field sun.nio.ch.SelectorImpl.selectedKeys
zeebe_monitor | WARNING: Please consider reporting this to the maintainers of com.hazelcast.internal.networking.nio.SelectorOptimizer
zeebe_monitor | WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
zeebe_monitor | WARNING: All illegal access operations will be denied in a future release
zeebe_monitor | 2020-09-09 03:32:58.038  WARN 1 --- [ient_1.cluster-] c.h.c.c.nio.ClusterConnectorService      : hz.client_1 [dev] [3.12.6] Exception during initial connection to [zeebe]:5701: com.hazelcast.core.HazelcastException: java.net.SocketException: Connection refused to address zeebe/.......:5701

Is there any other configuration as well, that needs to be done.

Hi @temp123, have you tried the simple-monitor configuration from https://github.com/zeebe-io/zeebe-docker-compose?


yes, tried from master, 18 and 23.1 branches and all failed.

The master branch of zeebe-docker-compose works for me.

Clone the repo, then:

cd zeebe-docker-compose/simple-monitor
docker-compose up

Works for me.