UnknownHostException when calling external REST from self Managed Docker


I’m having problems calling an external REST Mock endpoint when I run my process on local Docker compose. There is no problem when I run the process in the Camunda SaaS.

I get these log lines for the connector:

2023-09-29 10:59:30 2023-09-29T08:59:30.563Z  INFO 1 --- [pool-2-thread-7] i.c.c.r.c.outbound.ConnectorJobHandler   : Received job 2251799814128725
2023-09-29 10:59:30 2023-09-29T08:59:30.596Z ERROR 1 --- [pool-2-thread-7] i.c.c.r.c.outbound.ConnectorJobHandler   : Exception while processing job 2251799814128725
2023-09-29 10:59:30 
2023-09-29 10:59:30 java.net.UnknownHostException: 06b3017a-b86f-4517-bd8e-0c2653a12317.mock.pstmn.io
2023-09-29 10:59:30     at java.base/java.net.InetAddress$CachedAddresses.get(Unknown Source)
2023-09-29 10:59:30     at java.base/java.net.InetAddress.getAllByName0(Unknown Source)
2023-09-29 10:59:30     at java.base/java.net.InetAddress.getAllByName(Unknown Source)
2023-09-29 10:59:30     at java.base/java.net.InetAddress.getAllByName(Unknown Source)

I have tried to curl the endpoint from withing the connector instance, but then get “curl: (35) error:0A000126:SSL routines::unexpected eof while reading”.

Am I running into problems with our firewalls somehow, and can I fix it at the “Camunda level”?

Hello @Bjorn_S have you find a solution to this? I am facing the same issue.

I didn’t solve it on my laptop. Think it was firewall blocking stuff based on IT-department lockdown. I installed on my NAS and could happily continue…