User task: avoid trying to update a variable

In a process, I have a JSON variable that I am displaying in a user task.

While this part works, whenever I try to “complete” the task, Camunda tries to update said variable with its text representation, even if I set the field to “readonly”.

The docs implied a different behavior to me: User Task Forms |

readonly - Applicable to all types. Makes sure no input is submitted for the given form field.

So, the question is: how to avoid that behavior?

I even tried to provide an output mapping using an expression to explicitly convert to a JSON variable type, but to no avail.

The only way I get the task working is to set the variable to null in an output mapping.

Hello @enote-kane ,

welcome to the forum!

which type of form are you using?


Hi @jonathan.lukas ,

I am using generated forms, since camunda forms doesn’t allow to do that at all according to the docs. And embedded/external task forms are not an option since we don’t use process “applications” (we control deployments using the API).