Zeebe Node 1.0.0-alpha3 client available for testing

There is a Zeebe 1.0.0-alpha3 build available on Docker Hub.

This build of the Zeebe broker has the breaking changes to the client API that are coming in Zeebe 1.0.0.

I have published a 1.0.0-alpha.3 version of zeebe-node that implements the new API, and deprecates the pre-1.0 API.

You can install it with:

npm i zeebe-node@alpha

You should be able to use your existing applications written with the previous API methods, using the alpha zeebe-node package and the alpha Zeebe build, with deprecation warnings in your IDE, by simply installing the alpha package and connecting to the alpha broker, with one exception:

Worker handlers must now return the return value of a call to one of the deprecated complete.success(), complete.failure(), complete.forwarded() or complete.error() methods, or the new API methods job.complete(), job.fail(), job.forward(), job.error(), or job.cancelWorkflowInstance().

This allows your IDE to reason about bugs in worker handlers that cause a job to always time out in the worker. Refer to this issue for more details and examples of refactors that are required.

The work is being done on the 1.0.0 branch in this fork. Please refer to the README and the CHANGELOG for the release.

Please report any issues in the Camunda Community Hub Issue tracker for the Node client, and feel free to ask questions here in the Forum, or in the Camunda Cloud Slack.

Ok, tried new client and server.

changes made:
Everywhere “Workflow” changed to “Process”, everywhere “workflow” changed to “process”. Including elastic-search client, because zeebe-record-workflow-instance replaced to zeebe-record-process-instance. With this changes NodeClient and Elastic Search Client working ok.

  1. Operate still version 1.0.0-alpha2 and it cannot work with 1.0.0-alpha3 data so no visualization
  2. Everywhere complete.success replaces to job.complete, complete.failure changed to job.fail, complete.error changed to job.error.

At the beginning and tried old worker w/o changes but was getting a lot resource_exhausted, i do not know why. After changes everything seems worked as always. Except stress Test. It was getting a lot resource_exhausted. So stress was working slower than used with 1.0.0-alpha2 and old rules.
Maybe zeebe_broker 1.0.0-alpha3 change some backpressure policy.

P.s. used undocumented parameter pollInterval: 5ms, changed it to 100-300 ms and backpressure issue gone

1 Like