Automatically resuming process instances after server reboot

I am using the default Tomcat distribution with the shared engine. I have a very long running process that needs to always run. When I restart Tomcat (for a maintenance window, for instance), the running instance does not get restarted automatically. Is there a way to have all running instances be restarted automatically after an engine restart?



the running instance does not get restarted automatically

What exactly do you mean with that?


1 Like

I have attached a couple of screen shots from the cockpit. In the first image, I have started a test process and it is in a running state, waiting for a timer event. After I took that screenshot, I restarted the Tomcat server. When I went back to the cockpit the running instance was no longer there (the second screenshot). I plan on running multiple servers sharing a database, so we could have a rolling update window for the severs, allowing at least one server to be up at all times. I would like for this process to run forever, as long as there is a process engine running. Is there a way to make that happen automatically?


Hi David,

The process engine does not remove data on shutdown or restart by default.

  1. How did you configure the process engine?
  2. Which database do you use (no H2 in-memory, right?)



Thanks for the reply. I am just using the standard Tomcat distribution that I downloaded from the website, and a MySQL database (no in-memory database). I can check to make sure that I didn’t change something by accident. If I were going to change the default behavior, where would I change it?


Hi David,

This is configurable in bpm-platform.xml, but the standard file should be fine in this case.

  1. Can you check if the entries in ACT_RU_JOB (this table contains the jobs related to the timer) are the same before and after restart?
  2. How did you deploy the processes? If via a process application with processes.xml, make sure that the deleteOnUndeploy option is not set to true in processes.xml.



Sorry for the delayed response. We were in the process of moving our instance to docker, and after we did I continued to see the problem. I then looked in the processes.xml, and sure enough I found this:


Removing that line solved the issue and now the process continues to run through system restarts.

Thanks for the help!

Hi dmathes,

I am also struggling with this. What is the complete text of the line you removed? I can’t find “true” in processes.xml

Your help will be highly appreciated.

It was the setting “deleteOnUndeploy”. I had it set to true but it didn’t need to be.

Thank you so much.