BPMN Process 2.0 Deploy - Process doesn't show up

Hello Everyone,

I’ve been trying several times to create a camunda BPMN process that includes “META-INF” folder and processes.xml file through eclipse.
I’m actually using Maven inside eclipse to manage project dependencies.

So you could ask me: Why do you need a BPMN Process with processes.xml file.
In fact, I need this because my BPMN process starts automatically by a timer cycle that will run from X to X time.
If camunda goes down, for some reason, we want to keep this timer and not to restart it (this way we will lose track of everything that were counting previously).

By searching information on the internet I have found information about how to setup a java project for BPMN 2.0.

Every step of this tutorial goes well, the “.jar” file is created inside target folder and it’s build compiles successfully.

The problem arrives when i try to use this previous generated “.jar” file.
I have downloaded camunda community in order to host it in my local computer.
I already tried to copy that “.jar” file to “Root_Camunda_Folder”/internal/webapps and also to “example” folder.
Nothing happens and when i launch camunda and access it through localhost:8080, the process doesn’t show up.

Also I think that I’m using springboot version of camunda (community open source version downloaded from their website)

Am I Processing: bpmnprocesstest.7z…
missing some configuration that is needed on local camunda instance, to read the new BPMN Process .jar file?

Have you experienced this before?

Extra Information:

My pom.xml file:

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">







Processes.xml file

<?xml version="1.0" encoding="UTF-8" ?>
      <property name="isDeleteUponUndeploy">false</property>
      <property name="isScanForProcessDefinitions">true</property>

Java Class:

package com.org.camunda.bpmnprocesstest;

import org.camunda.bpm.application.ProcessApplication;
import org.camunda.bpm.application.impl.ServletProcessApplication;

public class StartClass extends ServletProcessApplication {
  // empty implementation

bpmnprocesstest.bpmn (3.0 KB)

Hi @CamundaNewbie and welcome!

I’m a little confused here. Are you using the Camunda-BPM-Run package? Or are you using Springboot to build your application? These are two entirely separate processes for building and deploying an application, so it’s important to figure out which one you’re using. From the description above it sounded like you were trying to deploy a Springbok application into the BPMN-Run engine, but I may have read it wrong. Could you clarify for me please?


Hi @davidgs thank you for the answer.

I have downloaded the open source community edition that appears as a “first option” on camunda’s website: Download Open Source Workflow Software | Camunda
On the bottom of the page you have other versions, but I’m not using them.

So yes, i’m trying to deploy a “.jar” camunda BPMN Process (developed inside Eclipse using Maven Project). The issue is that when i run my local camunda instance, the BPMN process doesn’t show up (seems that it is not being read by camunda run).

So far I do think that it is a springboot application.

Let me know if i’m not proceeding correctly or if there is a hint to better deploy / develop this process.

Hi @CamundaNewbie, and thanks for the response. Indeed, what’s happening is that you are ‘mixing metaphors’ as it were. You’ve downloaded and are running the Camunda BPM Run software, and are then attempting to build a Maven project and inject it into the Run platform.

I’d highly suggest watching the video series by the ever-informative @Niall . His videos are extremely easy to follow and well-done and will help you get a springboot application up and running in no time!

Hope this helps!

Hi @davidgs, thank you for the answer provided.

“You’ve downloaded and are running the Camunda BPM Run software, and are then attempting to build a Maven project and inject it into the Run platform.” Does that mean that the maven project (.jar) file shouldn’t work with Camunda BPM Run Software?

My main concern is related with deploying the springboot application and that information, unfortunately, is not available on videos.

If anyone has some tip to help me in this case, please tell me.
Really appreciate some support on this matter.

Does this bit of documentation help at all?


As David mentioned, you are trying to mix both Camunda Run and Camunda BPM. Here is the link for when it’s suitable to use Camunda Run.