Camunda 7.20 cockpit login screen not displayed due to an error in camunda-welcome-bootstrap.js


I’ve migrated my web service running an embedded Camunda process engine to:

  • Spring Boot 3.1.5
  • Camunda 7.20

The container is running in an AWS Fargate ECS behind an AWS Application Load Balancer. When I’ve previously migrated my environment to the AWS VPC, I had also troubles to get the initial login panel. I’ve added the following properties to the Spring Boot 2.X application:

  • Running behind an ALB → http locally, but https externally
    server.tomcat.use-relative-redirects: true

But now after the latest migration, the login screen is not coming and the following error is displayed in my Chrome console:

camunda-welcome-bootstrap.js?bust=7.20.0:2 Uncaught (in promise) TypeError: Cannot read properties of undefined (reading ‘customScripts’)
at camunda-welcome-bootstrap.js?bust=7.20.0:2:227742
at d (camunda-welcome-bootstrap.js?bust=7.20.0:2:220328)
at Generator. (camunda-welcome-bootstrap.js?bust=7.20.0:2:221665)
at (camunda-welcome-bootstrap.js?bust=7.20.0:2:220691)
at s (camunda-welcome-bootstrap.js?bust=7.20.0:2:227083)
at o (camunda-welcome-bootstrap.js?bust=7.20.0:2:228784)
at camunda-welcome-bootstrap.js?bust=7.20.0:2:228843
at new Promise ()
at camunda-welcome-bootstrap.js?bust=7.20.0:2:228724
at camunda-welcome-bootstrap.js?bust=7.20.0:2:228888

What I can see is that this last displayed URL is not working:
https://(server)/ → https://(server)/camunda/app/welcome/default/

But I can get the login panel if I provide the following URL:

How can I fix this redirection issue?

PS: After really clearing the cache when debugging my app, I have also the same error locally:


It may be related to the same javascript problems that stops form rendering in Tasklist, see Camunda Forms are not rendering in Tasklist · Issue #3885 · camunda/camunda-bpm-platform · GitHub .

For now there only option for me is to rollback to 7.19 until a fix is available (using Camunda CE, not EE).

My 2 cents

Not sure the 2 issues are related. After reading the issue report, I’ve tried the version 7.21.0-alpha1 locally: same behavior.

1 Like

Hi @lugon,

Thank you for reporting this.
Could you please share with us a minimal project example that reproduces the issue.
This will speed up the analysis of the issue.

Best regards,


Thx for the feedback.
I will try to provide you a sample project based on my app.


In my case simply rolling back to 7.19 (and Spring Boot 2.7.x) made the same forms work without other issues. Good luck!