Camunda 8.3 After upgrade started to fail

Hi Team,

I’ve been using Camunda for a while now, and all of my workflows were well with both self-managed and Camunda cloud. However, since updating to Camuda 8.3, none of my processes are working properly.

In my application, I’m getting the following warning messages.

2023-11-02 11:03:56.266 WARN 4839 — [lt-executor-518] io.camunda.zeebe.client.job.poller : Failed to activate jobs for worker updateRule and job type updateRule

io.grpc.StatusRuntimeException: UNAVAILABLE: io exception
at io.grpc.Status.asRuntimeException( ~[grpc-api-1.54.2.jar:1.54.2]
at io.grpc.stub.ClientCalls$StreamObserverToCallListenerAdapter.onClose( ~[grpc-stub-1.54.2.jar:1.54.2]
at io.grpc.internal.ClientCallImpl.closeObserver( ~[grpc-core-1.54.2.jar:1.54.2]
at io.grpc.internal.ClientCallImpl.access$300( ~[grpc-core-1.54.2.jar:1.54.2]
at io.grpc.internal.ClientCallImpl$ClientStreamListenerImpl$1StreamClosed.runInternal( ~[grpc-core-1.54.2.jar:1.54.2]
at io.grpc.internal.ClientCallImpl$ClientStreamListenerImpl$1StreamClosed.runInContext( ~[grpc-core-1.54.2.jar:1.54.2]
at ~[grpc-core-1.54.2.jar:1.54.2]
at ~[grpc-core-1.54.2.jar:1.54.2]
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker( ~[na:na]
at java.base/java.util.concurrent.ThreadPoolExecutor$ ~[na:na]
at java.base/ ~[na:na]
Caused by: connection timed out: /
at$AbstractNioUnsafe$ ~[netty-transport-4.1.84.Final.jar:4.1.84.Final]
at io.netty.util.concurrent.PromiseTask.runTask( ~[netty-common-4.1.85.Final.jar:4.1.85.Final]
at ~[netty-common-4.1.85.Final.jar:4.1.85.Final]
at io.netty.util.concurrent.AbstractEventExecutor.runTask$$$capture( ~[netty-common-4.1.85.Final.jar:4.1.85.Final]
at io.netty.util.concurrent.AbstractEventExecutor.runTask( ~[netty-common-4.1.85.Final.jar:4.1.85.Final]
at io.netty.util.concurrent.AbstractEventExecutor.safeExecute$$$capture( ~[netty-common-4.1.85.Final.jar:4.1.85.Final]
at io.netty.util.concurrent.AbstractEventExecutor.safeExecute( ~[netty-common-4.1.85.Final.jar:4.1.85.Final]
at io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks( ~[netty-common-4.1.85.Final.jar:4.1.85.Final]
at ~[netty-transport-4.1.84.Final.jar:4.1.84.Final]
at io.netty.util.concurrent.SingleThreadEventExecutor$ ~[netty-common-4.1.85.Final.jar:4.1.85.Final]
at io.netty.util.internal.ThreadExecutorMap$ ~[netty-common-4.1.85.Final.jar:4.1.85.Final]
at ~[netty-common-4.1.85.Final.jar:4.1.85.Final]
… 1 common frames omitted

Environment setup:

  • Machine : Mac M1 Pro
  • Java version : 17
  • Spring boot version: 2.7.5
  • camunda version : 8.3.0

Can some one please suggest the way to solve this problem ?

Raja Gandharaw.

Hi @GRajaMca - is this happening when your job workers are trying to connect to a local self-managed installation or SaaS or both?

Hi @nathan.loding , its happening for both.

Note: After lots of attempt figured out that this issue is inconsistency one.

What’s the cause for inconsistency? Versions of camunda components or configuration issue in charts?

@GRajaMca - what version of spring-zeebe / zeebe-client are you running? I’m not aware of any incompatibilities, but might be good to first make sure you are using the latest version.

You also said it was inconsistent. If you restart your application after you get the error, does it work correctly, or does it sometimes take a few tries? One other thing you can try is to use zbctl to try to connect to Zeebe when the Spring Boot startup fails. This would help eliminate your application as the issue and would point to something else (perhaps a networking issue of some kind?).

1 Like

@nathan.loding , @aravindhrs ,

We concluded that this problem is caused by some internal network configuration difficulties from the VPN after extensive testing.

Everything worked perfectly when I tried to reload everything on my local machine.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.