Camunda 8.4.0 Error when starting client application - failed to activate jobs

Hi Team, I am running camunda version 8.4.0 manual configuration on my machine.
In my client application I am using the dependency -

io.camunda.spring spring-boot-starter-camunda 8.4.0

However when I run my application , it fails to activate Jobs.I see follwoing warn messages and unable to perform any jobs.

[ERROR] DefaultNoopAuthentication - Unable to determine authentication. Please check your configuration
29-01-2024 20:23:21.819 main [INFO ] ZeebeClientProdAutoConfiguration - Creating ZeebeClient using ZeebeClientConfiguration [io.camunda.zeebe.spring.client.configuration.ZeebeClientConfiguration@5397d41e]

[WARN ] JobWorkerImpl - Unexpected failure to activate jobs
java.lang.NullPointerException: null
at java.base/java.util.HashSet.(HashSet.java:119)
at io.camunda.zeebe.client.impl.command.ActivateJobsCommandImpl.(ActivateJobsCommandImpl.java:66)
at io.camunda.zeebe.client.impl.worker.JobClientImpl.newActivateJobsCommand(JobClientImpl.java:88)

I also observed credentialProvider is empty - NoopcredentialProvider

I have set 2 properties in client application - zeebe.client.broker.gateway-address=127.0.0.1:26500
zeebe.client.security.plaintext=true
Please advise.

Hi @ShilpaN.Chalke - are you perhaps using Spring Boot >=2.7.x? I think there’s a bug with the 8.4.0 spring-zeebe package and it requires Spring >=3.x.x or you get this error.

ok.Thanks @nathan.loding I will upgrade to higher spring version and check
I have a question, If my client is on 8.3.4 version and my camunda engine runs on 8.4.0 will I still be able to have all features from 8.4.0.?

Another question. In an Openshift cloud If Auth is enabled, then I have to implement this credential provider class and create zeebeClient bean…is that correct ? What is the value for Zeebe_Authorization_server_url in self managed mode. Is it the Keycloak token url ?The documentation also says I can use environment variables as well directly.

Hi @ShilpaN.Chalke - Camunda 8.4.0 requires spring-zeebe 8.4. It’s possible that the 8.3.4 client version may work, but it isn’t supported. I believe the intent is for the 8.4 package to support Spring 2.7.x but there’s a bug.

The ZEEBE_AUTHORIZATION_SERVER_URL is Keycloak, I believe, and should be something similar to: https://<my-keycloak>/realms/<my-realm>/protocol/openid-connect/token/

I am specifically wondering what to do about the ERROR log message

ERROR : Unable to determine authentication. Please check your configuration 

My setup is:

  • Zeebe client 8.4.0
  • Zeebe broker 8.3.5
  • Spring Boot 3.2.2

EDIT: Broker 8.4.0 does not resolve the error log message

Hi @Frantisek_Svoboda, welcome to the forums! Are you trying to connect to SaaS or a Self Managed instance (I assume Self Managed)? If Self Managed, did you configure your instance with Identity?

1 Like

Thanks @nathan.loding

Any idea when this bug may be fixed ?

Hi @ShilpaN.Chalke - I don’t, unfortunately. But spring-zeebe is open source and we welcome pull requests, if someone in the community can get to it sooner!

for 8.4 engine - 8.4 client combination we have to use springboot 3.x.- if we are using springboot-camunda community library in your client
There is a bug with this library if you try to use 8.4 client with springboot 2.7.x

ok. thanks

Thanks - it must be the identity then, will look into that. Cheers