Camunda 8 Docker Compose

I have done Camunda 8.2 setup with docker compose. Below aer the steps we followed

  1. Downloaded GitHub - camunda/camunda-platform: Links to Camunda Platform 8 resources, releases, and local development config
  2. Issues the command docker compose -f docker-compose-core.yaml up -d
  3. When I access the tasklist with the url localhost:8082 i am able to access it. But when i exposed it over the internet and tried to access it its giving the error “session expired just now” as soon as logging in.
    Has anyone faced a similar issue. or do i need to change any configuration?

Hi @priyaprabhu , how exactly are you exposing your locally running Docker containers and how are you trying to access them?

We are making a reverse proxy on the http server of the linux box where we are running the docker compose. such as and direct to the port 8082. and i am accessing it with the url I am similarly doing for other services such as to 8081 and to 8083. i am able to successfully login to optimize, operate but not in tasklist

Hi All.
To fix this issue i replaced the identity url from localhost:18080 to (The Reverse proxy) in the docker-compose yaml file and this worked.