Camunda ACM Plugin in Camunda Wildfly 7.4.0-Final


currently i try to get the Camunda-ACM-Plugin to work. Building the jar was successful, but i think i havent placed it in the right wildfly folder.

I’m using the Camunda Wildfly 7.4.0-Final version and deployed an CMMN example from the underwriting-example:

The readme says “The resulting JAR file must be packed inside the Camunda Webapp WAR”. I have placed it into the “camunda-webapp-jboss-7.4.0.war” folder (with 7-Zip):

But in the camunda cockpit i can only see BPMN-Processes and DMN Decisions, no CMMN.

Maybe you can tell me, what i’m doing wrong? I write my Master thesis, where i have to use CMMN and it would be great to use this plugin.

Thanks a lot for your help!

There are a number of unsolved issues with the acm plugin and 7.4
You can see those issues here:
If you want to help out, please feel welcome …

The one you mentioned is only minor: there is no CMMN navigation entry, but you can still get the cmmn view by navigation through “deployments”.


In addition to Jan’s comment, you also placed the resulting JAR in the wrong location. JAR Libraries are put into ‘WEB-INF/lib’-folder in a WAR file.


hello together,

I have the same problem as Andy. However I got not as far as he. I also tried it with 7zip but i got an error message from the browser.

In the readme of the Camunda-ACM-Plugin it is mentioned: “The resulting JAR file must be packed inside the Camunda Webapp WAR”. I tried it with 7zip and i can put the ACM-jar inside the camunda-webapp-jboss-7.4.0.war and it is also deploying but when I try to open the tasklist with my browser a 404 Error Message appears.

My question is. How can I properly pack the resulting Jar file inside the camunda-webapp-jboss-7.4.0.war ->WEB-INF/lib -folder?

Thx for your time