Camunda Modeler cannot connect to Zeebe Cluster

Hi,

I have enabled TLS for Zeebe gateway and Zeebe broker, but the issue is I cannot connect to the Zeebe cluster through the desktop modeler.

I use kubectl port-forward command forwarded the zeebe gateway port to local. The spring-boot application could successfully connect to zeebe cluster to get the topology and deploy bpmn processes with the same trust cert but the camunda modeler cannot.

I have added the TLS flag for Camunda modeler:

flags.json:

{
  "zeebe-ssl-certificate": "~/Desktop/Camunda/API Investigations/JAVA APPS/demo-process/src/main/resources/certs/grpc-gateway-chain.pem"
}

I’m using the Camunda 8 Self-Managed version (8.1.4) and deployed on k8s environment.

Have anyone met this issue? Thanks.

Not that this is the likely cause, but have you tried using

https://localhost:26500

rather than what’s configured in your screenshot (http://localhost:26500 )

the S in there instructs the software to wrap/unwrap the communications with TLS, so if you have one side configured to use TLS and tell the other side not to use TLS, they won’t be able to talk.

Hi @GotnOGuts ,

Thanks for your reply.

I have tried both HTTP and HTTPS, none of them work and the same error prompts.

I want to check the modeler logs, but not knowing where to find it.

Hi,

application log can be found on Mac in ~/Library/Logs/Camunda Modeler/log.log. You can run the following command to quickly copy it: cat ~/Library/Logs/Camunda\ Modeler/log.log | pbcopy.