Camunda Modeler- Credentials do not match with the server

Dear community,

I’m new with Camunda and try to deploy the standalone version 7.15 on an existing Tomcat server.
The application is working but I’m not able to deploy a diagram to the Camunda Platform.

My rest Endpoint is http://xxxxxxxxx:8080/camunda/api/engine/engine/default

If I enter the Username and Password I’ll get the error popup “Credentials do not match with the server”

Any ideas?

Thanks a lot


Hi @michael1
Could you attach a screenshot where you enter the Username and Password and the error popup “Credentials do not match with the server”?

Hi Alex,

here you are.

Thanks. A few more questions.

  1. Can you log in with this user to Camunda Cockpit?
  2. Please show how the Authorizations are configured for the user in Camunda Admin.

I can access camunda with this account. It is the admin user account you enter the first time to get access to the tool.

Sorry, just a silly guess based on that you have “Remember credentials” checked. Did you try to re-enter the Password to make sure there is no typo?

I’ve reentered the password with the same result. Just as an addition information, the REST easy API is used in the standalone version.

Are you able to deploy a diagramm without the Modeler? I mean using some 3rd party tool like Postman and REST API?

Unfortunately I’m not able to setup Postman in a very short time in my environment. If I use the standalone version I do not know how to use the rest API.
Anyway, I’ve deployed the Camunda run Platform in parallel on another port. With this version no credentials are needed to be inserted in the modeler. This will solve my problem.
If you like to investigate further on the credential problem, I can let the standalone version deployed for some testing.

Hi @michael1,

it seems that you deploy through the api endpoint of the Camunda Web App. This endpoint has a Cookie-Based security which is not implemented in the Camunda Modeler.

Please use the rest endpoint instead: http://XXXX/engine-rest.

Hope this helps, Ingo

1 Like

Hi Ingo,

thanks for the hint. My server is currently in maintenance. I will try this as soon it is availbale again.


the standalone version of Camunda is not available anymore on our Tomcat server and I’m not able to test anything. With the Camunda Platform run it works well for me. How the topic will be closed?

Thanks a lot to anybody trying to help me!

Have a good day


Hi @michael1,

there is no special procedure to close the topic.

Just describe what you did so that other readers with the same problem can see how to get it solved.

You can check that post as a solution as well.

Hope this helps, Ingo