Camunda Optimize https connection with camunda engine

Hello Team,

I am trying to connect my camunda engine from camunda-optimize over https, but i am not able to connect it. Do you have user guide to configure the connection over https.

Thank you

Are you trying to set up the Camunda engine over https? Or set up Optimize over https?


My camunda engine is running as a https server and i try to connect camunda instance to my camunda engine(https)

I am getting below exception
17:40:47.369 [EngineImportScheduler-1] ERROR o.c.o.s.i.e.f.instance.TenantFetcher - Error during fetching of entities. Please check the connection with [camunda-bpm]!
org.camunda.optimize.service.exceptions.OptimizeRuntimeException: Engine didn’t respond. Can not verify this engine’s version
at org.camunda.optimize.service.util.EngineVersionChecker.checkEngineVersionSupport(
at org.camunda.optimize.service.importing.engine.fetcher.EngineEntityFetcher.getEngineClient(
at org.camunda.optimize.service.importing.engine.fetcher.instance.TenantFetcher.performTenantRequest(
at org.camunda.optimize.service.importing.engine.fetcher.instance.TenantFetcher.lambda$fetchTenants$0(


Hi @ggupta011 ,

Thanks for clarifying. Have you verified that all the connection URLs you’re using are, in fact, correct? The error appears to be saying that

it cannot connect properly. What versions of the engine and Optimize are you running?



I am using camunda version 7.16.0 and i can access the camunda apis in postman.

A similar error has popped up in a few other threads.

Check your SSL Keystore in your Optimize instance. If Optimize cannot establish a valid SSL connection to the BPM server, it will claim that the server didn’t respond.

1 Like

Hi @ggupta011,
You can configure SSL certs in Optimize using
"OPTIMIZE_JAVA_OPTS=-Xms1024m -Xmx2048m<path to keystore.jks><path to truststore.jks>"
Error in logs are a bit misleading and do not suggest that there may be error in SSL communication.
I hope the Camunda team will fix the logs.

Hello @hrishi_joshi

Even after tried above mentioned configuration, It is giving me the same error.
Currently i am using the trial version of Camunda optimize. Is it something related to trial version issue?

Gaurav Gupta

Hi @ggupta011 ,
I am not sure, but dosen’t seem like a license related issue.
How are you running the Camunda engine and Optimize?
Have you verified if you can access the Camunda Engine URL from Optimize server(using curl maybe).
You could also verify if plain HTTP connection works or not so you can see if the issue is related to the network connection itself or only with HTTPS.

Hi @ggupta011 ,
in addition to what @hrishi_joshi already suggested, could you please also post your Optimize configuration, specifically the parts relating to your engine connection.
Also, which version of Optimize are you using? Version 3.8.3 includes a change that improves the logging of errors that can occur with the engine version checker, so updating to that patch may give you further details in the logs as to what causes your connection issue.