Camunda Rate Limiting across the workflow

Hi Team,

I’m looking for a way to interact with the rate limit with camunda.


I have a case in which the user uploads a csv file, and each row of the csv file must be processed and pushed to a third-party system via Rest.

However, because the third-party system has rate limiting features, we are receiving Too Many Requests errors from the server on a regular basis.

Because file execution and other tasks are handled by workers in asynchoronus mode, how can I construct a rate limit function to limit the amount of hits from my system?

Could someone please advise on the best approach to accomplish this?

Thanks & Regards,
Raja Gandharaw.

Hi @GRajaMca,

you can configure your worker with maxJobsActive=1. Job worker | Camunda 8 Docs

Then the jobs are fetched one by one and send to the backend one after another.

Hope this helps, Ingo

1 Like

I believe this question is related to this one: Reactive zeebe client (vert.x)
maxJobsActive parameter doesn’t work. Once worker thread is released by calling asynchonous code, it thinks the job is done and take another one.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.