Camunda Rest api 'POST /deployment/create' to upload bpmn file gives : 404

Getting a 404 when attempting to upload a simple bpmn following the below tutorial
POST /deployment/create - following the tutorial :

“timestamp”: “2019-03-27T15:47:42.437+0000”,
“status”: 404,
“error”: “Not Found”,
“message”: “No message available”,
“path”: “/engine-rest/deployment/create”

My configuration :
Spring-Boot: (v2.1.1.RELEASE)
Camunda BPM: (v7.10.0-ee)
Camunda BPM Spring Boot Starter: (v3.2.0)

You’ll probably want to use the endpoint “/rest/deployment/create”

Tried that too - same result … Here i am trying to start a process thats deployed on startup instead of via rest api (which works via the Cockpit - Start process) but get the below when using the Rest interface to initiate the same

“timestamp”: “2019-03-27T16:42:58.330+0000”,
“status”: 404,
“error”: “Not Found”,
“message”: “No message available”,
“path”: “/rest/process-definition/key/Process_1/start”

This issue is a show stopper as we cannot communicate with Camunda engine over http if this is not working … :neutral_face:

Can you upload your process?

Can you also share your pom.xml?

1 Like

ipl.bpmn (4.7 KB)

pom.xml (4.3 KB)

You might try to add this dependency:

1 Like

The key of the process is IPL not Process_1

So the call you’d need to need to call the process with the call:

What else could i try… please suggest.

why are you using the port 8085 in your rest call?

I had to change port to 8085 via application,properties file since the 8080 is taken by some other app running on my laptop

Aaha … so there is a static dependency on port 8080 :slight_smile: … I changed it to 8080 and it worked … will do for now but i guess this should not be the case in long run .

Thank you for responding with options to try and the videos help a lot!!