Camunda-SpringBoot-Oracle connexion issue

Hello Camunda community,
I’m relatively new to Camunda and I have troubles creating a usable Oracle connexion in my Camunda Spring Boot development :
Oracle version : 12.1
Oracle driver successfully installed with Maven : ojdbc7-
Our connexions Oracle are done via ldap : jdbc:oracle:thin:@ldap://ldap-tns1:4035/cn=OracleContext,dc=oracle,dc=chuv/camunda_db_dev

This ldap connexion works well for others applications.
The Oracle schema is up and running well.
The error is as follows :

java.sql.SQLException: L’URL Oracle indiquée n’est pas valide
at oracle.jdbc.pool.OracleDataSource.getPhysicalConnection( ~[ojdbc7-]
at oracle.jdbc.pool.OracleDataSource.getConnection( ~[ojdbc7-]

We use the yaml file to create the sping.datasource : here is the oracle connexion part (i removed the camunda engine db hikari/h2 part) :

    active: "dev"
      banner-mode: "off"
    driver-class-name: oracle.jdbc.OracleDriver
    url: jdbc:oracle:thin:@ldap://ldap-tns1:4035/cn=OracleContext,dc=oracle,dc=chuv/camunda_db_dev
    username: camunda_app
    password: XXXXXXXXXX
    test-on-borrow: true
    validation-query: SELECT 1 FROM dual
    max-active: 5
   database: Oracle
   database-platform: org.hibernate.dialect.Oracle10gDialect 

I also have a DataSourceConfiguration class as follows : (i removed the camunda engine db hikari/h2 part) :

public class DataSourceConfiguration {

   * Datasource engine properties.
  private EngineDataSourceProperties engineDataSourceProperties;

  private OracleDataSourceProperties oracleDataSourceProperties;

  public DataSourceProperties businessDataSourceProperties() {
	return new DataSourceProperties();

  public OracleDataSource businessDataSource() {
	return businessDataSourceProperties().initializeDataSourceBuilder().type(OracleDataSource.class)

And finally the OracleDataSourceProperties class :

@ConfigurationProperties(prefix = "") //oracle.datasource
public class OracleDataSourceProperties extends DataSourceProperties {

  private String driverClassName;

  private Charset sqlScriptEncoding;

  public OracleDataSourceProperties() {

  public String toString() {
    final StringBuilder sb = new StringBuilder();
    sb.append(", url=").append(this.getUrl());
    sb.append(", username=").append(this.getUsername());
    sb.append(", password=").append(this.getPassword());
    sb.append(", sqlScriptEncoding=").append(sqlScriptEncoding);
    return sb.toString();

  //  Getters ///////////////////////////////////////////////////////////////////////////////

  public String getDriverClassName() {
    return driverClassName;

  public Charset getSqlScriptEncoding() {
    return sqlScriptEncoding;

  //  Setters ///////////////////////////////////////////////////////////////////////////////

  public void setDriverClassName(String driverClassName) {
    this.driverClassName = driverClassName;

  public void setSqlScriptEncoding(Charset sqlScriptEncoding) {
    this.sqlScriptEncoding = sqlScriptEncoding;

Any suggestions ?
Thanks for the help

It will be easier to provide solutions if the post in English.

Can you translate the exception message and post it, if possible?

java.sql.SQLException: The Oracle URL indicated is not valid

By the way I’ve made progress : I did some cleaning in my spring configuration (correct use of @ConfigurationProperties and json metadata of parameters and yaml file), and now I can connect to the Oracle DB, but a new error is sent back by the Oracle Driver :

java.sql.SQLException: ORA-01017: invalid username/password; logon denied
	at oracle.jdbc.driver.T4CTTIoer.processError( ~[ojdbc7-]
	at oracle.jdbc.driver.T4CTTIoer.processError( ~[ojdbc7-]
	at oracle.jdbc.driver.T4CTTIoer.processError( ~[ojdbc7-]

I am 100% sure of my user/password.

I found some problems with this ojdbc driver in the following post :
But I’m not sure it’s related to my problem

Refer this post, might be helpful:!topic/dbfit/7zSgetsgyLs

I tried this morning a direct connection to the db with ldap, without any spring configuration… and it works perfectly well. So finally it might be a problem between spring boot, yaml config, the driver version.
Any suggestion on the security part of an Oracle driver and spring ?

Here is the class :

package ch.chuv.poc.dmn;
import java.sql.Connection;
import java.sql.DriverManager;
import java.sql.ResultSet;
import java.sql.SQLException;
import java.sql.Statement;
import java.util.Properties;

public class CamundaOracleConnectionTest {
    public static void main(String[] args) {

      Connection conn = null;
      try {

        String dbURL = "jdbc:oracle:thin:@ldap://ldap-tns1:4035/cn=OracleContext,dc=oracle,dc=chuv/camunda_db_dev ldap://ldap-tns2:4035/cn=OracleContext,dc=oracle,dc=chuv/camunda_db_dev";
        Properties properties = new Properties();
        properties.put("user", "camunda_app");
        properties.put("password", "XXXXXX");
        conn = DriverManager.getConnection(dbURL, properties);
        Statement stmt = conn.createStatement();
        ResultSet rs;

        rs = stmt.executeQuery("select IPP, PRENOM, NOM, SEJOUR from PRN_INPUT_GROUPES");
        while ( ) {
          String ipp = rs.getString("IPP");
          String prenom = rs.getString("PRENOM");
          String nom = rs.getString("NOM");
          String sejour = rs.getString("SEJOUR");
          System.out.println("ipp = "+ipp+" prenom = "+prenom+" nom = "+nom+" sejour = "+sejour);

        if (conn != null) {
          System.out.println("Connected with connection #3");
      } catch (ClassNotFoundException ex) {
      } catch (SQLException ex) {
      } finally {
        try {
          if (conn != null && !conn.isClosed()) {
        } catch (SQLException ex) {

It finaly worked with my db connexion. It was a spring boot configuration problem. Basically, the application.yaml should be like :
active: “dev”
banner-mode: “off”
url: jdbc:oracle:thin:@ldap://ldap-tns1:4035/cn=OracleContext,dc=oracle,dc=chuv/camunda_db_dev ldap://ldap-tns2:4035/cn=OracleContext,dc=oracle,dc=chuv/camunda_db_dev
username: camunda_app
password: XXXXXXXX
driver-class-name: oracle.jdbc.OracleDriver
sql-script-encoding: UTF-8 oracle.jdbc.xa.client.OracleXADataSource