Camunda-webapp cockpit not loading


I am using enterprise version [camunda BPM] v7.10.0-ee

I have added the dependency with pom to my spring boot webapp.
When I mvn clean install everything works fine.
Once I start the app, I am able to login and land on welcome page, but once I click on any of the subpage like Cockpit, Admin, Task I get error like below

The same app is working fine for other developer. What might be the issue? I have proper internet connection and I am able to see enterprise dependencies are loaded as expected.

Below is the exception trace

2020-08-17 22:06:12.273  WARN 18888 --- [nio-8080-exec-3] ExceptionHandler                         : It was not able to load the following file 'app/plugin.css'.
at org.camunda.bpm.webapp.plugin.resource.AbstractAppPluginRootResource.getAsset(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at org.glassfish.jersey.server.model.internal.ResourceMethodInvocationHandlerFactory.lambda$static$0(
at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher$
at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.invoke(

Hi @Deepak_Naik,

I would suggest cleaning up your browser cache in case you already used the browser to load Camunda webapps before. Beside that we will need additional information to investigate further: application properties file, pom.xml, did you perform an upgrade, or it was not working at all, record HAR file, etc.

As you are using enterprise version, I would recommend to create a support ticket:

Best regards,

1 Like

Thank you Yana.

I tried accessing in brand new browser and facing same issue. It works fine in dev/test environment.
Not sure how to generate HAR file.

First time camunda user here.
I just followed the official “Quick Start” using the docker container to run camunda.
I got as far as step “Deploy the process” and then failed at Verify the Deployment with cockpit
Error messages in my browser console look very similar

This is on Kubuntu 20.04 (but should that matter when I am running the camunda in docker?).
Happens on both Firefox and Chromium. Also happens when I try it in a new private window.

I am kind of sad that I did not even made it through the Quick Start without problems :cry:

When I use the tomcat version instead of the docker container it works fine.

You can follow this guide to generate HAR file:

Which tag version of the docker image do you use?
I would recommend switching to fix version, like 7.13.0 (the latest minor release).
In case you use the latest tag, we have an issue building those tags at the moment.

Yes, that explains it. Note that “latest” is used right at the top of your own Download and Installation page.

Thanks for the answer. At least that gives me some confidence that I can get solutions to future problems in the forum.

Thank you for the hint.
I created CAM-12313 where you can track the progress for the tag fix.

Hi having the same issue then above.
I am trying to get the Camunda WebApps running. Added the webapps dependencies and when i am trying to access the UI getting the error that couldnt load several.js

In my Spring Boot Application i am getting the error
/camunda/app/cockpit/styles/styles.css httpCode=404
/camunda/lib/require.js httpCode=404

Is there anything i am doing wrong?
Additional Information:
using springboot 2.3.1 Release and added the camunda-bpm-spring-boot-starter-webapp 7.13.0 as dependency

In UI i am getting following error:

Hello @Timo1,

Your url seems to be incorrect for version 7.13.0, how did you end up there, if you checked some Camunda docs/guides, please let us know to verify them. Read further here:
Also could you please try to clear your browser cache.

If the above doesn’t help. Please share detailed steps to reproduce the issue and generate a HAR file.


Hi Yana,

the URL just comes from testing if it might work with the old URL.
If i use the out-of-the-box URL getting the same issue:

Steps to reproduce it

  1. Adding the spring-boot-starter-webapp dependency into your spring-boot project
  2. Starting the Application
  3. Opening Browser and getting to /camunda/app/cockpit

Please find attached also the HAR (saved as log)localhost.log (36.9 KB)

Hi ,

please suggest if there is solution for this issue as We are also facing same issue for admin : - some resources from the camunda-webapp-webjar lib (some css and js) are not found. Chrome gets a 404 when trying to download these resources, and the UI becomes unusable.

Tried camunda version 7.13.0 and 7.16.0.

I’m still facing this with 7.15.0-ee edition. Any help would be appreciated