Camunda WebApp is stuck on loading

I have a setup Camunda using Spring Boot. When I run Spring Application, the APIs are working fine. But the webapp seems to be stuck on loading. This seems to be an issue related to security.

I have tried clearing cache. But this error persist. I have tried both on Chrome and Edge, and both are stuck on loading.

:8080/workflow/camunda/app/admin/default/setup/#/setup:1 Refused to apply style from 'http://localhost:8080/workflow/camunda/api/admin/plugin/adminPlugins/static/app/plugin.css' because its MIME type ('application/json') is not a supported stylesheet MIME type, and strict MIME checking is enabled.
:8080/camunda/api/admin/plugin/adminPlugins/static/app/plugin.js?bust=7.13.0:1 Failed to load resource: the server responded with a status of 404 ()
require.js:1 Uncaught Error: Script error for "admin-plugin-adminPlugins/plugin"
    at makeError (require.js:1)
    at HTMLScriptElement.onScriptError (require.js:1)
:8080/camunda/app/admin/default/setup/#/setup:1 Refused to apply style from 'http://localhost:8080/camunda/api/admin/plugin/adminPlugins/static/app/plugin.css' because its MIME type ('application/json') is not a supported stylesheet MIME type, and strict MIME checking is enabled.


Spring-Boot: (v2.2.1.RELEASE)
Camunda BPM: (v7.13.0)


same issue here. any help?

I am also facing the same issue. any help?

@Niall I am stuck here too any suggestions? What I did is just added in my spring boot application, API which is generated with the Swagger OPEN API. I dont call anywhere this API I just generated them and somehow it is crashing but my APIs are with completely different names so I dont understand why this http://localhost:8080/my-app/camunda/app/tasklist/default/ link does not work. Any ideas?

Hi @hahi
I think your issues is different to the one described in this post.
Can you create a new topic of your own where you explain the problem your having in detail.


I am also facing similar issue. Not able to load cockpit.

Any suggestions on how to proceed.

Hi Same issue for me . Can anyone please reply if u did solve this issue…

There are a lot of possible issues that can cause this.
Without details about the project’s pom.xml and the application.yaml it’s hard to diagnose.

So please add these details to your question :slight_smile:

1 Like

我也遇到同样的问题,一直卡在加载中,我用的版本 camunda7.15 ,

Hi Everyone,

I am also facing the same issue, updated my camunda version to 7.15,apis are working fine but UI is not working.

As i see from Network tab in chrome some issue with plugin.css and plugin.js?bust=7.15.0

1 Like

Hi @Digraj22,

sometimes it helps to simply clean the browser cache after an upgrade.

Hope this helps, Ingo

1 Like

I tried doing that…it didn’t work

but this one helped me CAM-10738 to get running using intellij Run configuration. With gradle boot run it’s still the same(UI not loading)

Had the same issue. 2 things to be checked which helped me to solve it:

  1. Check if Windows is not blocking run file.
    Go in Windows to “Windows Defender Firewall and Advanced Security”->Action->Properties.
    In each opened tab go to Settings->Customize and mark “Display a Notification” = Yes.
    Then please try to run again start-camunda.bat to see if all is OK or some notification is provided if to run or not program
    2.Check your browser. For me it did not work with Internet Explorer. Use Edge/Chrome, make it as Default and then web-app launched to me perfectly

I am also facing the same issue.

Hi there!
I’m also facing the same issue and the solutions here do not resolve mine

I had the same issue running locally camunda-bpm-spring-boot-starter-webapp 7.17.0 in Intellij
Finally, changing the SpringBoot Run configuration “Shorten command line option” to @argfile solved this issue