Can not connect to Camunda Engine

Hello all,
we are in evaluation stage of Camunda’s Enterprise Edition, but we face a technical issue that is a road block to our evaluation process. I will try to describe our technical issue on my best of my knowledge.

  1. We have a created a simple demo process as shown below. This is just a simple process so as to understand how we can deploy it in the engine. As shown, the key is “process_test”.


  1. We have deploy it on Cockpit. So, we are able to see the process there, but we want to try to create a new instance automatically.

  2. We tested the REST API with POSTMAN, and it really works.


  1. Now we want to do this implementation with javaScript code. We want when an end user submits a new application, a new process instance to be created on backend with all the user’s information to be available in camunda’s engine.

For this reason, we created just a very simple html code and javascript code, instead of testing it in our real website. In the following images, the simple js code is shown. This code is fired when an end-user clicks on submit button. But as you can see we face an CORS-policy error.



  1. We tried it also in another way, namely with XMLHttpRequest, but in this case we face another issue.

When the button is clicked in the html code, the following javascript code is fired. But as you can see, we have the following error about CORS policy.



  1. Then, in another topic in the forum, we saw some suggestions to add CORS header server wide in the WildFly standalone.xml. Like shown below, we also did this step.


  1. After the server is restarted, we are not able to connect to the server.


So, after all, we guess that is an issue with the server, but we cannot deal with it.

I hope we could soon find a solution so as to continue the evaluation of Camunda’s Enterprise Edition capabilities. I hope now its really clear the issue that we face.

Thank you all for your time and apologize for the long topic.

Kind regards,

The images are not visible. can you update your post?

Hey Niall, I repaste the images.

  1. My simple process

  2. The REST API works in postman.

  3. My simple js code.

  4. Error occured. camunda4

  5. Even if I try with XMLHttpRequest as shown below, I face an issue.


  1. I applied some suggestions that I saw in another topic about CORS policy.

  2. I still face an error.camunda8

Hope it helps to understand my issue and how it can be solved.

Have you looked through this post:

It seem to be covering the same issue.

I receive the following error when I paste the code from this post.


@Niall Niall sorry for asking again, but do you have any ideas on how to fix it??
Unfortunately, this issue is a road block to our evaluation process.

@nikolaosnousias Instead of having ‘*’ for header-value just configure the host and check.

Try like this:

<response-header name="Access-Control-Allow-Origin" header-name="Access-Control-Allow-Origin" header-value=""/>

@aravindhrs I still face the issue that I described above. My code is as shown below:

			<buffer-cache name="default"/>
			<server name="default-server">
				<http-listener name="default" socket-binding="http" redirect-socket="https"/>
				<host name="default-host" alias="localhost">
					<location name="/" handler="welcome-content"/>
					<filter-ref name="server-header"/>
					<filter-ref name="x-powered-by-header"/>
					<filter-ref name="Access-Control-Allow-Origin"/>
					<filter-ref name="Access-Control-Allow-Methods"/>
					<filter-ref name="Access-Control-Allow-Headers"/>
					<filter-ref name="Access-Control-Allow-Credentials"/>
					<filter-ref name="Access-Control-Max-Age"/>
			<servlet-container name="default">
				<file name="welcome-content" path="${jboss.home.dir}/welcome-content"/>
				<response-header name="server-header" header-name="Server" header-value="WildFly/10"/>
				<response-header name="x-powered-by-header" header-name="X-Powered-By" header-value="Undertow/1"/>
				<response-header name="Access-Control-Allow-Origin" header-name="Access-Control-Allow-Origin" header-value=""/>
				<response-header name="Access-Control-Allow-Methods" header-name="Access-Control-Allow-Methods" header-value="GET, POST, OPTIONS, PUT"/>
				<response-header name="Access-Control-Allow-Headers" header-name="Access-Control-Allow-Headers" header-value="accept, authorization, content-type, x-requested-with"/>
				<response-header name="Access-Control-Allow-Credentials" header-name="Access-Control-Allow-Credentials" header-value="true"/>
				<response-header name="Access-Control-Max-Age" header-name="Access-Control-Max-Age" header-value="1"/>

Could anyone please help me out? I want to resolve it asap